4.10 parrot tty1

Briefly describe your issue below:
parrot upgraded tp 4.10 tty1? but no gui. is there a command to install gui for the version? I have tried all the sudo cmds on redditt

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.10 tty1
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
usb
Configured to multiboot with other systems? (yes / no)
yes with macOS
If there are any similar issues or solutions, link to them below:
Lot of similar issues with previous versions like 4,5 and 4,4 and recently 4.8, haven’t seen 4.10 out in the wild yet.
If there are any error messages or relevant logs, post them below:

have you tried
sudo parrot-upgrade
?

Yes. Tried everything:
“Actually this will probably work better, try”

Sudo apt remove --purge parrot-interface* && sudo aptitude install parrot-interface*

There is a Reddit blog:
Deleted xorg or parrot interface solution

ParrotOS no GUI, Parrot Linux no user interface, parrot security no desktop environment, parrot Linux removed xorg
connect to WiFi from the command line in linux

Sudo apt update

Sudo apt install aptitude

Sudo aptitude parrot-interface-full

That should fix it.

If that doesnt work try

Sudo apt install parrot*

Or

Sudo aptitude install parrot*

I have update parrot but during update a lot of error comes such as ncscript has overloaping and after update no changes in desktop

please make sure you are using
sudo parrot-upgrade to upgrade the OS

I have upgrade my parrot using this command only.but during update it download all packages successfully but when installing some type of error such has ncriscpt had overlapping and after full update there no update in graphics the desktop graphics is not being changing