4k UHD movie files very laggy?

Briefly describe your issue below:
I have a few 4kUDH movies at 2160p. I have a 15 inch hp pavillion with a 4k screen and nvidia graphics card 970m. Before I switched to parrot I would use VLC media player and have no issues. Ever since I switched to parrot and I want to watch any videos sometimes even 1080p videos but mainly 4k the video is just laggy. And it cant be internet since the video is downloaded, and I already tested it on my windows machine and it works just fine.

My question is, Am i suppose to install nvidia graphics drivers to fix this issue? Im almost certain I have not done that since switching my OS. Ive also tried MPV media player built into parrot.

Any sugggestions or ideas? Much much appreciated.

What version of Parrot are you running? (include version, edition, and architecture)
Static hostname: parrot
Icon name: computer-laptop
Chassis: laptop
Machine ID: 13216f455bxxxxx7d41690
Boot ID: 68dbe7a1c9xxxxx7ad3ee4fa
Operating System: Parrot GNU/Linux 4.5
Kernel: Linux 4.19.0-parrot1-20t-amd64
Architecture: x86-64
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
Not that I was able to find
If there are any error messages or relevant logs, post them below:

What does laggy means ? Does the system freeze or is the image kind of fractured at some moment ?

Sorry I should have been more clear, Laggy as in losing alot of frames. Consistently losing frames and watching them at a very noticable lower frame rate. When I watch that same file on my win10 machine using vlc its clear as day at about 60fps

Is there anyway to check if I have the nvidia drivers installed? I see an Nvidia X Server Settings in my menu but when I click to open that nothing happens.

EDIT: When I do

sudo apt install nvidia-driver

this is the error I get. So im assuming it has to do with my nvidia drivers not being installed properly?

The following packages have unmet dependencies:
nvidia-driver : Depends: nvidia-driver-libs (= 410.93-2) but it is not going to be installed or
nvidia-driver-libs-nonglvnd (= 410.93-2) but it is not going to be install

Upon furthur research when I run

lspci -v

in my console under my GTX card this is what its displaying.

02:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev ff) (prog-if ff)
!!! Unknown header type 7f
Kernel modules: nvidia

Use SMPlayer instead of VLC. Change smplayer’s skin to papirus as default one looks ugly.

This is odd, you have only one gpu right ? If you didnt installed any driver nouveau should be carrying on.

Try to install one of these and then try again to install nvidia-driver.

Well techincally two GPUs. My Laptop has intergrated graphics with my i7 and I also have a nvidia gtx 960m that I thought would just work out of the box with linux but I guess not.

No nvidia and Linux are kind of in a bad period, making them work take some time and energy. So what i advise for you is to follow this tuto:

But before doing that, update your system by doing:

sudo parrot-upgrade

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.