64 bit Parrot installation failed

I am trying to install Parrot 64 bit in my Laptop HP 430 but it is failing on installation step after 7% or more.

I tried parrot 3.9, 3.11 and 4.1 Ver
But all Fail

Parrot 32 bit OS was working fine in my laptop but 64 bit is not installing.

I tried Rufus, Win32 disk imager, poweriso, and rosaimager and many more tools to create pendrive bootable

I tried both Debian Standard / Debian GTK installation

Etcher is the officially supported image writer.
Check the partition type (MBR / GPR, use mbr), once it cause me a headache too

Is your Computer running 32bit processor or 64bit processor?

64 bit Processor

64 bit Windows and 32 Bit Parrot was working fine on it (Dual Boot)

Still same error, even after using Etcher

It is failing to install system after 7-10%

Is there anything I can do for this ??

when the error message appears, please press CTRL+ALT+F4 and send us a clear and readable picture of the error message.

then press CTRL+ALT+F1 or CTRL+ALT+F5 to go back to the installer and shut it down properly.

We will be able to help you once you send us this screenshot.

Of course you have to make sure to download the latest version of Parrot. This means that you have to trash 4.1, 3.11 or any precedent version and make sure to have Parrot 4.2.1 or later.

then follow the guidelines described in the following links:




Thanks to all
Parrot 4.2 worked
Successfully installed after many efforts
Thanks again

you should run 64 bit in your computer supports it.