About DNS problem in Parrot 4.8

Dear users,

We are having a very annoying issue in Parrot 4.8 that users can’t access internet. Browser and everything shows error “Can not resolv address”. Our team is able to spot the bug. So here is possible reasons:

  1. The AnonsSurf: There are people shut machine down without turn AnonSurf off. AnonSurf, overall, is a bash script that forward your all traffic to Tor network. Palinuro didn’t think about that problem when he developed it. It is actually a known issue and we tried to fix that before. There are more and more users have this problem because we are having more regular users so they don’t know (or they forgot to check) DNS configuration. So i have developed new version of AnonSurf for months, the problem was properly fixed in development patch. It was never be released because of “in development” reason and that was my responsibility for that. I’m very sorry for my bad at work and i can’t give you the best quality. We are working on core part and trying to release it in next version. I also create a fast script that can help you fix DNS problem faster by using calling the tool instead of do something manually. So, we have the fix in the tool and the other way to fix problem just in case our tool still has something wrong.
  2. Palinuro spotted there are bugs in drivers and user’s system couldn’t get the DNS address from DHCP server. It happens on fresh installation of Parrot. In this case, we are rolling distro, we are providing latest version of Linux kernel so there are network drivers can’t work on our distro and ofc we can’t spot it all. This problem should be on the Debian side and it would be nice if you could open issue on Debian so they can fix them and we pull the patch fix. Again, if you still have problem, i hope my script can be released asap so you can fix it with single command (or edit resolv.conf if you want).

So thank you all for all support for us! We are still working hard to improve our quality! Thank you and stay safe!

1 Like

No 1 happed to me with anonsurf a longtime ago.
My mistake was that i enabled anonsurf and did not disable it after
What i did to solve it was to enable anonsurf again and disable it

1 Like