adattatore wifi

con parrot 4.8 tutti gli adattatori wifi non funzionano, ho provato con parrot 4.7 live e funzionano

Puoi fornirci maggiori dettagli in modo che possiamo aiutarti meglio?

1 Like

le chiavette wifi, ne ho 3 o 4 il sistema le vede ma quando clicco connetti e inserisco la pass prova qualche secondo e fallisce, pensavo fosse un mio problema con il sistema installato ma anche parrot 4.8 live fĂ  uguale, mentre con parrot 4.7 live funzionano bene. se provo con airgeddon a fare una scansione con la chiavetta wifi la mette in monitor mode ma quando avvio la scansione dice errore imprevisto

il pc è vecchio con il bios

la scheda di rete del pc si connette, però andando a vedere dmesg vedo che fà continuamente autenticazioni

questo dice dmesg provando la chiavetta

[37621.595992] iwlwifi 0000:0c:00.0: Radio type=0x1-0x2-0x0
[37621.721006] iwlwifi 0000:0c:00.0: Radio type=0x1-0x2-0x0
[37644.815627] usb 4-2: new high-speed USB device number 13 using ehci-pci
[37644.853575] usb 4-2: New USB device found, idVendor=0cf3, idProduct=9271, bcdDevice= 1.08
[37644.853581] usb 4-2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[37644.853585] usb 4-2: Product: USB2.0 WLAN
[37644.853588] usb 4-2: Manufacturer: ATHEROS
[37644.853592] usb 4-2: SerialNumber: 12345
[37645.123593] usb 4-2: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[37645.123811] usbcore: registered new interface driver ath9k_htc
[37645.187053] usb 4-2: firmware: direct-loading firmware ath9k_htc/htc_9271-1.4.0.fw
[37645.479659] usb 4-2: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[37645.731699] ath9k_htc 4-2:1.0: ath9k_htc: HTC initialized with 33 credits
[37646.006680] ath9k_htc 4-2:1.0: ath9k_htc: FW Version: 1.4
[37646.006686] ath9k_htc 4-2:1.0: FW RMW support: On
[37646.006688] ath: EEPROM regdomain: 0x809c
[37646.006690] ath: EEPROM indicates we should expect a country code
[37646.006692] ath: doing EEPROM country->regdmn map search
[37646.006694] ath: country maps to regdmn code: 0x52
[37646.006696] ath: Country alpha2 being used: CN
[37646.006697] ath: Regpair used: 0x52
[37646.013308] ieee80211 phy1: Atheros AR9271 Rev:1
[37646.490630] ath9k_htc 4-2:1.0 wlx14cc20183695: renamed from wlan1
[37661.721286] wlx14cc20183695: authenticate with 60:14:66:d3:73:b5
[37662.038288] wlx14cc20183695: send auth to 60:14:66:d3:73:b5 (try 1/3)
[37662.070810] wlx14cc20183695: authenticated
[37667.039767] wlx14cc20183695: aborting authentication with 60:14:66:d3:73:b5 by local choice (Reason: 3=DEAUTH_LEAVING)
[37668.721187] wlx14cc20183695: authenticate with 60:14:66:d3:73:b5
[37669.028409] wlx14cc20183695: send auth to 60:14:66:d3:73:b5 (try 1/3)
[37669.032868] wlx14cc20183695: authenticated
[37674.031831] wlx14cc20183695: aborting authentication with 60:14:66:d3:73:b5 by local choice (Reason: 3=DEAUTH_LEAVING)
[37676.048874] wlx14cc20183695: authenticate with 60:14:66:d3:73:b5
[37676.343630] wlx14cc20183695: send auth to 60:14:66:d3:73:b5 (try 1/3)
[37676.348047] wlx14cc20183695: authenticated
[37681.344308] wlx14cc20183695: aborting authentication with 60:14:66:d3:73:b5 by local choice (Reason: 3=DEAUTH_LEAVING)
[37683.901150] wlx14cc20183695: authenticate with 60:14:66:d3:73:b5
[37684.206130] wlx14cc20183695: send auth to 60:14:66:d3:73:b5 (try 1/3)
[37684.210546] wlx14cc20183695: authenticated
[37686.005208] wlx14cc20183695: aborting authentication with 60:14:66:d3:73:b5 by local choice (Reason: 3=DEAUTH_LEAVING)

cercando su google dice che il problema è il nome lungo che il sistema dà all’interfaccia

ho trovato questo comando che dicono risolve il problema , ln -s /dev/null /etc/systemd/network/99-default.link , ma risponde cartella giĂ  esistente , ho provato a cambiarli nome con iw phy set name ma non cambia nome ( con i nomi giusti)

perfavore guarda

https://community.parrotlinux.org/t/wifi-not-connecting-and-wlan1-name-changed-fixed/11003/7

1 Like

sono riuscito, non nella maniera corretta, dando il comando ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules e cambiando scheda prima in wlanmon e poi in manager il nome diventa wlan1 e si connette, la maniera corretta dovrebbe essere dare il comando ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules e riavviare service network-manager, ho dimenticato di provarlo, perchè questi esperimenti li faccio in live per paura di combinare un guaio, ma dovrebbe funzionare

allora service network-manager restart non funziona, ma ho pensato che forse basta inserire la chiavetta dopo aver dato il comando, proverò

si funziona

1 Like

grazie :slight_smile: :wink:

1 Like

Sono felice che tu l’abbia fatto funzionare :slightly_smiling_face:

1 Like