[adm-edited] KDE can't find konsole

Briefly describe your issue below:
After upgrading (sudo parrot-upgrade), and installing ‘firejail’, I am receiving a error that ‘konsole’ cannot be found. It was a regular install on separate media ~ kde… I also have a bios error that bios has blocked text.

What cannot be found".konsole " method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

1 Like

There are some users are having this problem. Let me check the problem and find a solution.

@dmknght
I assume “Error code 100, Could not find the program ‘konsole’” is the same issue faced by KDE Parrot OS users

2 Likes

its the same issue as my post of june 8. Dns Fix/Set.
Today did a fresh instal and the Dns Fix/Set function worked, after the update it again showed (Error-Plasma could not find program ‘Konsole’)
bing

2 Likes

Thank you. confirmed it is affecting multiple users. Now i have to check kde lab to see.

Solution: Wait for KDE for the bug fix.
This might be PATH bug of kde.

This morning did another fresh download and install of 4.9.
Everything worked so did sudo parrot-upgrade and hey presto…The dreaded MATE returned and KDE banished!!!
KDE LIVES MATTER.

As a temporary fix I have utilized the following as a solution:
1: sudo apt update
2: sudo apt install parrot-kde
3: sudo apt purge --auto-remove mate* parrot-mate libmate-desktop*
4: sudo apt-mark hold mate-desktop parrot-mate libmate-desktop*
5: sudo apt full-upgrade
6: sudo apt clean && sudo apt autoclean
7: sudo reboot
Its currently unpacking but there is no sign of MATE.
Dont yet know about Htop,DNS fix,etcf and the cannot find Konsole but I am waiting with baited breath.
I hope these recent upsets can be fixed and that for next upgrade I can rest in peace.
Suerte
bing

just a follow up.Did a reinstall, which took 4 hours!!! no MATE but still cant find Konsole, even though i am using Konsole???Something clearly not right, whole system is like using an early IBM.
Hope you can find the issues.
Bon Chance
bing

yeah about the konsole its a bug from KDE side as said in earlier post.
You need to wait for next update patch

Thank you so much for the reply. As mentioned earlier the application paths were incomplete.
regardz,

thomas

Thank you…

I fixed some by correcting working path etc…

Best regardz,

thomas

A solution would be nice.

same issue. Just after updating the OS from APAC Server.

I too have the same issue and KDE settings will not honor selection of another terminal. Parrot identifies as 4.10 running plasma 5.17.5 on the 5.6.0-2 real time kernel

I am having the same issue here with neovim text edit,vim text editor and some others in the utilities section at the start menu. I just installed and update my parrot yesterday.

whoever are facing konsole not found problem still
you can either change the default terminal or
manually specify /usr/bin/konsole at the default terminal location
that will fix the issue
@bebop210 @Xen1al