"Advanced MATE Menu" / mate-menu, Keeps failing to open with keyboard shortcut

update: I got killall mate-menu assigned to a keyboard shortcut, but it keeps asking me to prompt restarting it, which works but I can only click it with the mouse.

I tried:
[killall mate-menu | sleep 2s && xdotool key ‘Right+KP_Enter’ ]

which looks like it works, but it actually doesn’t.

“Advanced MATE Menu” / mate-menu, Keeps failing to open with keyboard shortcut.

I can select “Remove From Panel” and re-add it and then it usually starts working again.

Is there a terminal command, where I can just kill and restart the menu as a work around?

terminal commands: mate-menu, and /usr/lib/mate-menu/mate-menu.py both don’t seem to do anything.

No idea what the root cause is, but a workaround would be fine.

Hi Theblob,
I hope to be useful to you. I do this: to set the keyboard shortcuts I go to System → Preferences → Hardware → Keyboard Shortcuts. If I want to kill a process, from the terminal I give the command ‘ps ax’ to get the list of active processes; each process is marked with a number at the beginning of the line; then I give the command ‘kill -9 process number’ to kill the process I want to kill. Note that to kill some processes you need to be logged in as root

thanks for this, the kill -9 process number seems to work the same, prompting me to ask if I want to reload.

For now its ok, but it’d be nice if parrot team could just stop mate-menu keyboard shortcut from randomly dying. Not a big deal, but a nice to have.

1 Like