After Updates, no Wifi Adapters work anymore

I need help with the following problem:
I downloaded ParrotOS 4.7 mate the day before yesterday and installed it on a Thinkpad E495 as a second partition next to Win10.

After installation, my following wifi adapters are recognized directly by ParrotOS 4.7 and also work perfectly:

  • Alfa awus036NHA (chipset: Atheros AR9271)
  • Ralink RT3070 (maybe an RT3070L, not sure)
  • Realtek RTL8812AU

After installation, ParrotOS asks me whether updates should be searched for and installed. As soon as I answer this request and the approx. 1600MB updates have been loaded and installed, none of my wifi adapters will work.

Realtkek ​​RTL8812AU:

  • iwconfig: adapter is no longer recognized.
  • lsusb: adapter is recognized.
  • However, ParrotOS informs me that the current firmware is already installed and does not have to be updated if I want to reinstall it via DKMS.
  • if I install the update via aircrack-ng / RTL8812AU via git, make + make install, the adapter is not recognized either.

Ralink RT3070:

  • iwconfig: The adapter is not shown as wlan0 or wlan1 as before, but as wlx00c … 6d.
  • lsusb: adapter is recognized.
  • If I want to connect the adapter to my Fritz! Box 7360 router via WLAN, an attempt is made to establish a connection, but the connection can never be established.

Alfa awus036NHA:

  • exactly the same as with the Ralink RT3070
  • iwconfig: wlx00c … 20.
  • lsusb: adapter is recognized:
  • WiFi connection the same problem

Realtek Wireless-AC 8822BE (2x2) (This is the Laptop’s built in Wifi card)

  • This adapter doesn’t work after clean install of ParrotOS 4.7 nor after running updates Parrot asks for.
  • iwconfig: does not show the adapter at all.

I nearly think about simply not letting ParrotOS carry out updates, because without updates with a fresh installation of Parrot 4.7 everything runs perfectly.

ParrotOS 4.7 security mate fresh install + all new updates installed.

Graphical install through with USB 3.0 Stick

Multiboot with windows 10 pro. Win 10 first installed, Parrot as second partition afterwards.

Realtkek ​​RTL8812AU
Ralink RT3070
Alfa awus036NHA
Realtek Wireless-AC 8822BE (2x2)

So far, solutions are just not to run any updates right after ParrotOS 4.7 clean install

1 Like

I am having the EXACT same issue right now and it is very frustrating. My post is here https://community.parrotsec.org/t/best-way-to-update-hp-vendor-debian-or-kernel/11023/2

I also have Alfa and a TPLink tht won’t connect. My alfa isn’t even being recognized by my ports. It does not light up. In my Live ISO that I havn’t updated my wifi adapters show up just fine. I have been troubleshooting and trying to find methods to solve this. I will share the links with you. Hopefully it will work. But so far for me, they havne’t worked and the only conclusion I’ve come up with is that I have to recompile the kernel so it can recognize my drivers and firmware.

Ok, so here is what I’ve done so far.

This is a PDF to get a general feel of how to install a TP Link Driver. Not sure if you use TP Link, but the vendor should have something on their page about it.

This did not work for me

This is an article showing how to get ALFA up and working. I’ve used these steps in the past and was able to fix the issue, however it did not fix it this time for me.

Another solution that did not work for me: https://askubuntu.com/questions/981638/alfa-awus1900-driver-support

This is for the Realtek RTL8812AU, however it did not work for me

This did not work for me: https://community.tp-link.com/en/home/stories/detail/323

This driver could supposedly be used as an alternative in some cases, but it did not work for me: https://github.com/jeremyb31/rtl8192eu-linux-driver

Here are some good troubleshooting methods on Debian’s page
https://wiki.debian.org/WiFi

Although my wifi adapter is specifially stated on here as the ONLY tested and confirmed device to work- nope! lol it doesn’t! (TP-Link TL WN821N )

So then I went to parrot docs about how to recompile the kernel.
https://docs.parrotlinux.org/trbl/custom-kernel/

I have been trying since last night. I am getting errors when I try to recompile. I am going to use these directions now https://www.kernel.org/doc/html/latest/

The ones listed under parrot doc are not working for me, and most likely I am the one doing it wrong lol. But the first sentences from parrot doc state this about why someone would need to recompile the kernel:

Why would someone need to recompile the ParrotOS kernel.Maybe someones wants the kernel to handle special hardware,maybe optimize the boot time by removing useless drivers,maybe to create a monolithic kernel instead of a modularized one,maybe to run a newer or in development kernel,maybe to add new patches,drivers or kernel features that are not included in the stock ParrotOS kernel.Or maybe just to learn more about Linux kernels.Whatever is the case the follwing guide will show you how to do it.

Also, because Parrot uses Debian and Debian says this:

"Availability of compatible WiFi chipsets

Currently there are only a few modern wifi chipsets readily available that work with free software systems. For USB wifi devices this list includes the Realtek RTL8187B chipset (802.11G) and the Atheros AR9170 chipset (802.11N). For Mini PCIe all cards with an Atheros chipset are supported"

On this list from Debian https://wiki.debian.org/WiFi your device should be able to work. However, it also says the same for my TP Link and tht is not the case.

I am going to try to recompile the kernel. It seems that is the only way.

sidenote I also get the message that the drivers are already installed and lsusb does recognize my wifi adapters, but my alfa doesnt light up. I also changed UEFI settings with the ports and this didn’t help

2 Likes

Whow… you put a lot of effort in your post :star_struck: I really do appreciate this mate!!!

Alright, i will give you a short update of what I have managed to get working so far, but still I am so frustrated by now that I am really installing a clean new parrot 4.7 mate and than just keep it like this. Everything worked before the update and it really doesn’t matter if I update now, tomorrow or in a month. Hopefully in a couple of weeks an update will be able without these problems.

Ok, so let’s start:

  • I managed to get the Wifi interface names for Realtkek ​​RTL8812AU, Ralink RT3070, Alfa awus036NHA right again. So if you iwconfig in terminal they show up as wlan0 wlan1, and so on instead of instead of “wlx00c … 20”.

Realtek Wireless-AC 8822BE had already not been showing up in Kali Linux or ParrotOS 4.7 with or without updates. So I decided to put this problem on last place for things that need to get solved.

This is what helped me solving interfaces’ names problem:

  • I managed to get the WiFi adapters connecting to my wlan network again.

After the WiFi interface names had been changed back to their default names (wlan0, wlan1, etc) they were all able to connect to my WiFi network.

But let me tell you, since I changed back the interfaces to default I am not able to set up a fully working evil twin attack in airgeddon. All services can be created correctly but my wlan0mon is not able to set its SSID to the attacked network’s SSID (which, as we all know, plays the most important role in evil twin).

So be careful with the link I added above.

veo

1 Like

AWESOME!

I’m so glad you got it to work! I also have the weird interface names for wifi and I fixed the issue, however I still wasn’t able to connect. Right now I am my using my laptop with 4.7 Live with no updates. I can connect fine.

On my other machine where I did sudo parrot-upgrade, it is a disaster.

I will try the medthod above tht worked for you and I will be back to tell you if it worked or not.

For the Realtek 8814 / your 1900 model, did you try this?

It is for 8812 AND 8814 and last updated not too long ago.

veo

1 Like

I tried something similar in both links you just posted, but not the EXACT steps. So I will try. I hope it works!

Try this out:

add these 2 lines lines to “/etc/NetworkManager/NetworkManager.conf”

[device]
wifi.scan-rand-mac-address=0


then restart network-manager by typing in terminal:
“sudo service network-manager restart” or reboot.

Then type in terminal:
“sudo ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules”

then reboot.

It’s way too late for me already, gotta get some sleep. It’s 4:30 in the morning :wink: So I won’t be able to reply a couple of hours, just so you know.

veo

3 Likes

Maybe you will find some time to check the evil twin in airgeddon, after you have managed to get your WiFi running again :slight_smile:

As I mentioned earlier, I got my WiFi running again by following those steps BUT evil twin was not running correctly any more (unable to change the wlan0mon SSID name to targets SSID name.

veo

1 Like

My Alfa is now up and running!!! Thanks so much!

This is the link tht helped me https://github.com/aircrack-ng/rtl8812au

My interface names have also changed and are showing correctly as wlan0 and wlan1, however my tp link wifi adapter is still not working. I really don’t care about that at the moment though lol. I am grateful I can connect to wifi with at keast 1 adapter!

Thanks again!!

1 Like

Oh just in case, let me mention if other people have the same problem.

After I rebooted and tried to connect, it did not work. I had to run this command:

sudo depmod -a

Then I was able to connect!

1 Like

Ok I tried the evil twin attack in airgeddon and I could not put the Alfa in monitor mode, apparently the name changes when it tries to put device in monitor mode.

However, just for kicks I tried to put my TP Link WiFi adapted in monitor mode and it worked?! So weird that I can’t even use it to connect to WiFi, but I can put it in monitor mode. I didn’t even know this WiFi adapter could do this. I think it’s a mistake?

(The name of the Alfa wifi adapter changed to “10”)

Alright,

what Alfa card do you exactly have?

you might wanna try putting it in monitor mode by using the terminal without airgeddon. command:

sudo iwconfig
(check which wlan your card is. Let’s assume it is wlan1)

sudo ip link set wlan1 down
sudo iwconfig wlan1 mode monitor
sudo ip link set wlan1 up
sudo iwconfig
(check if it wlan1 now says monitor mode)

also try:
sudo ifconfig wlan1 down
sudo iwconfig wlan1 mode monitor
sudo ifconfig wlan1 up

maybe this gets you in monitor mode.

veo

I think i misunderstood some words you said :sweat_smile:
my problem with the awus036ach after update it didn’t show up at all

“apt install realtek-rtl88xxau-dkms” is at neawest version and every thing should work fine but it does’t

How I Fixed It:

i removed the driver
#cd /usr/src
#sudo rm -r rtl88.12au “Remove driver repo”

#su “then input root password to run all next commands as root”

update your repositories
#apt-get update

install dkms if it isn’t already
#apt-get install dkms

change directory to /usr/src
#cd /usr/src

install the driver from github
#git clone https://github.com/gordboy/rtl8812au.git

move into downloaded driver folder
cd rtl8812au/

make drivers
#make

move into parent directory
#cd

debugging
#dkms status

rename file for use with dkms
#mv rtl8812au/ rtl8812au-5.3.0

dkms add driver
#dkms add -m rtl8812au -v 5.3.0

build drivers
#dkms build -m rtl8812au -v 5.3.0

install drivers
#dkms install -m rtl8812au -v 5.3.0

debugging
#lsmod

reboot
#reboot

Wifi interface should now appear.

I can now see my Alfa interface but Airgeddon can’t use it because its now using something called “Auto”.
See here for more info from the dev of Airgeddon:


Is a way to edit the driver to use monitor or managed instead of auto?

I tested aircrack and it works fine in monitor mode …
Try it manualy throw:

#If config wlan0 down
#Iwconfig wlan0 mode monitor
#Ifconfig wlan0 up

It will work fine , what i’m trying to fix is when i put it in monitor mode throw aircrack it doesn’t change to wlan0mon it change to monitor mode but stays wlan0

And another problem with reaver:
┌─[root@parrot]─[/home/v0rt3ex/Desktop]
└──╼ #wash -i wlan0
[X] ERROR: pcap_activate status -1
[X] PCAP: generic error code
couldn’t get pcap handle, exiting

I did try to manually witch it. For some reason it stopped recognizing the alfa adapter for a little bit of time.

I found a plugin for airgeddon that takes care of the problem:

after adding this to the airgeddon plugin directory its all working.

I can only tell you my experiences about the wlan0 in monitor mode.

I experienced this too, monitor mode on but wlan0 staid wlan0 instead of switching to wlan0mon but my wifi adapters worked rgardless of wlan0 or wlan0mon.

Is your adapter not working right when set to monitor mode with wlan0 interface?

YOU SIR ARE A LIFE SAVER HOW DID SOLVE THIS SOLUTION? IVE BEEN TRYING FOR WEEKS TO SOLVE THIS THANKS!!. you saved me

1 Like

You are welcome :heart: ,

To save a few extra days in monitor mode with alfa awus036ach:

Ifconfig wlan0 down
Airmon-ng check kill
Iwconfig wlan0 mode monitor #(iw)*
Ifconfig wlan0 up

Ur ready to go test with airodump-ng or aireplay :wink: