Almost one week with parrotsec

parrotsec

(rowie) #1

Hi,

after a bit of experimenting here a little summary of my findings:

  • every reboot my keyboard layout switch back to EN - set to DE - Austria (no deathkeys). :slight_smile:
  • starting anonsurf from the shell with “sudo anonsurf start” work´s
  • starting from the Menu doesn´t work.
  • KB Layout for encrypted LVM is EN … when you entered it in German in the setup … you will fail on first reboot.
  • the mlan0 Wificard on the Surface 4 goes after some time into Powersave Mode and only a reboot wakes it up (blacklisting helps) :wink:

I will continue happy testing … maybe on my other devices (raspi3, MS Surfacebook, …) too.


#3

Thanks for the info!


(rowie) #4

And here is how i start to fix my problems … :slight_smile:

edit the /etc/default/keyboard file:

change "XKBLAYOUT=“en” to “de”
add “nodeadkeys” to XKBVARIANT

and then:

sudo dpkg-reconfigure keyboard-configuration
  • reboot … don´t know if necessary! :slight_smile:

i start it from the shell :slight_smile:

i setup a passphrase that´s the same in en and de layout :stuck_out_tongue_closed_eyes:

ok, i think blacklisting is no longer necessary! i ´ve only add the folowing to the “/etc/NetworkManager/NetworkManager.conf” file:

[connection]
wifi.powersave = 2
[device]
wifi.scan-rand-mac-address=false
  • reboot

if someone wants to add something to it … Please feel free !! :grinning:

br,
rowie


(dmknght) #5

the mlan0 Wificard on the Surface 4 goes after some time into Powersave Mode and only a reboot wakes it up (blacklisting helps)
I don’t really understand this part. But, as far as I understand, my BCM43142 is having same issue (wlan 0 - normal mode, no monitor mode at all). It happens on both Debian and Parrot. Looks like I have new information about this weird problem.


#6

Thanks for your notes, I will see what we can do to fix some of these.


(rowie) #7

if i type
iwconfig
i see power - on.
if this is enabled, my wifi card disconnects after some minutes from my wifi ap. only a reboot makes a new connection to any wifi possible.
card is in managed mode … not monitor mode.
i hope these make sense for you :slight_smile:


(rowie) #8

fine!!! let me know if you need more information! :wink:


(dmknght) #9

So it is the same here. I believe restart network-manager service will make it work (sometime I have to restart multiple times).
p/s: I thought it was because broadcom driver is unstable


(dmknght) #10

What is your wireless device again?


(rowie) #11

02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88W8897 [AVASTAR] 802.11ac Wireless