Ancestris Genealogy Program

Briefly describe your issue below:

Unable to run. Installed with gdebi package.

What version of Parrot are you running? (include version, edition, and architecture)
4.2.2
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
debian standard
Configured to multiboot with other systems? (yes / no)
yes
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
┌─[don@parrot]─[~]
└──╼ $ancestris
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.netbeans.ProxyURLStreamHandlerFactory (file:/usr/share/ancestris/platform/lib/boot.jar) to field java.net.URL.handler
WARNING: Please consider reporting this to the maintainers of org.netbeans.ProxyURLStreamHandlerFactory
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
UI class not found, using default UI…

Try this

sudo update-alternatives --config java 

found here

Thanks for the info but I still get the same error. This program works on Debian .

Try sudo ancestris maybe? I’m really not sure about that one. What are the dependencies?

I would probably direct you to their community forum because from what I have read a lot of them also have been experiencing issues lately so if you have java all squared away and all depends met it might be an issue with the package, it seems like you have a general handle on using Debian so I’m going to lean more towards Debian issues since I saw a lot of the posters were using ubuntu

I have done further testing and have found Ancestris runs fine on Debian Stretch with zero errors but I get the above mentioned error when I run it on Debian Buster. I guess I will have to wait until someone from Debian Testing updates and fixes the problem. Don’t know what else to do. Not smart enough to fix.

1 Like

No shame there, if everybody had the brains/sense to be capable of configuring linux distros with anything and everything you could imagine; well, then I suppose the world would run a lot smoother… glad we exonerated parrot from the offenders list!

It is not a Parrot problem, looks like Debian Testing needs some work. Thanks for your assistance in working through this.

It was an interesting read actually, I enjoy genealogy, being a transplant myself I have roots that seem to pop up everywhere! Just out of curiosity were you the one with over 6500 family members you can trace? That is really really cool #knowledgeispower

Yes I have over 6500 people in my Genealogy. I am 77 yrs. old and have been working on genealogy for 40 years.

1 Like

That’s fascinating! No doubt easy as pie with how we keep records… :roll_eyes: you sir must be a patient and highly curious individual! How did you get started and is ancestris your favorite genealogy software?

My favorite genealogy program is Brother’s Keeper but it only runs on Windows and I hate windows! Ancestris is a gedcom editor so you need to know a little about GEDCOM. Got started when my wife wanted to join Daughters of the revolution and just never stopped.

1 Like

My aunt is a member of that group! Small world! You immediately got a like for the windows sentence… I barely tolerate it…

This looks like an issue with the java runtime package to me. My box (Linux Mint) was configured to use java-11-openjdk-amd64, and I was getting the same error. After running sudo update-alternatives --config java as described above, and dropping down to openjdk version 8, it fired right up. Hope this helps.