Anon Surf and Root user issues

Briefly describe your issue below:

Hey all!

I’ve been running ParrotSec OS on a virtual box for about a year, I decided to remove windows from my machine and installed from a live boot. I noticed a couple things that I’m having issues with.

  1. The root account cant access apps like firefox. The page will just never load. Same thing with trying to run apps from the terminal.

  2. When I try to activate Anon Surf from my primary user account (not root obviously) the script will run and it will say that I’m connected however after performing a verification I can see my IP is not going through the TOR net. When I activate anon surf on the root account however I can see I am going through the TOR net, but I also can’t run any apps from the root.

I have tried searching the forums with no luck. I’m appreciative of any help that I can get from anyone!

Thank you so much in advance!

Version 4.18.0-parrot10-amd64 GNU/Linux

I installed from a live USB… I’m pretty sure I’m not configured to boot with other systems either as I wiped the harddrive and this is the only one installed on my box.

Sounds like firejail was possibly updated from what you’re used to, its been through a lot of changes the past few months. Possibly could explain the firefox but I’m not sure on that one…

I thought so too. The only issue with that is I can’t launch from the terminal using any firejail commands either on the root account.

I’m able to use all applications on a sudo account besides anon surf.

If i login as root i cant use firefox either. If you open it via the command line you can see the errors, you might be able to fix it but im not sure why you would need to use firefox as root anyway.

For anonsurf maybe post the commands you are using and the output.

I have no intention of using root to do anything other than system administration offline. However when I was testing Anon Surf on my sudo account there are no errors that show up. It actually says runs the script, closes any open windows and says I’m under the tunel. Then if I test my IP it shows my true IP if I’m not connected to a VPN.

Thanks for all the feeback so far, I’m super confused!

Anonsurf doesnt connect you to a VPN anyway, but i know what you mean.

What are you using to test your IP?
Something is not working properly, i would suggest typing out the commands manually and seeing if any of them fail. Or copy anonsurf to you documents and add in some extra debugging then start it from there.

I know it doesn’t connect me to a VPN. I’ve run into a few other problems. Maybe you can help out :sunglasses:
Here is a link to an issue I opened up Network Problems AnonSurf

When I’m outside of the TOR net if I ping I have no problems.

When I run: ping I get the following
ping: Temporary failure in name resolution

So it seems to be a DNS issue but I’m not sure how to fix this. I’d love any help that anyone can give.

I had the same problem and solved it by giving my account sudo rigths. Have you tried giving sudo rights to your non-administrative account? I don’t know if you want to do that? I did that for an account I use only for surfing the net. It has it’s own password too. Here is what you can try. You can also try going sudo and add your user account to Firejail.

apt-get install sudo
usermod -a -G sudo

You could also try adding yourself in .config. Open your file browser as root, show hidden files and ad youself to etc/firejail/firejail.users. Remember many of the apps here are sandboxed.

Good luck.

1 Like