Anonsurf issues after "apt full-upgrade"

  • OS version: run cat /etc/*release
    Parrot GNU/Linux 4.10
  • Kernel version: run uname -a
    5.7.0-2parrot2-amd64 SMP Debian 5.7.10-1parrot2

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.10
Desktop Environment: Mate
Edition: Security

_virtual.ova  & amd64.iso 

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?
VMware install 
Oracle VM Virtual Box
  1. How did you install OS?
    Default

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

```
    Ubuntu Host - Xeon Workstation
```

4. How did you get this error? Are there any steps to procedure it?

Both are fresh installs:

VMware without "apt full-upgrade" allows the anonsurf through cli and GUI to run without issues. 

Oracle VM Virtual Box with "apt full-upgrade" does NOT allow anonsurf through cli and gets errors through GUI.

This is can be repeated on VMware after "full-upgrade"

5. Error log or screenshot

From cli 
![Screenshot from 2021-02-13 17-08-36|362x157](upload://mgqX8DyFSchLw843t1MT4Y1SviJ.png) 
From GUI
![Screenshot from 2021-02-13 17-09-29|452x284](upload://2ndVRJJG1Lmvuuvwiq8FJMwtGgK.png) 
![Screenshot from 2021-02-13 17-13-35|664x292](upload://vZduAZedw38NTiH4VUKYeL9Nkvt.png) 

From Non-updated/Upgraded 
![Screenshot from 2021-02-13 17-11-32|547x499](upload://mvzgRy0LpZZvvJaSNmcbMEtTdcG.jpeg) 

6. If you have any idea or suggestion about this issue please tell us

This is repeatable with VMware and VBox but tested it to make sure the .ova or .iso was a problem with the update and/or upgrade.

The results are the same...

3. Any other information about this idea

I initially was having issues with the Anonsurf and Tor connections with the upgraded system and wanted to double check the systems and updates and found this problem. 

My issues were connection issues which resulted in my host machine would be disconnected from DHCP. My issue is persistent and nothing seems to fix the problem of the past issues on this thread from @dmknght   

###### https://community.parrotsec.org/t/internet-stop-working-after-ive-started-anonsurf/13027 #####

This very well could be an issue on my end as I am new to Parrot.