Anonsurf no connection

Briefly describe your issue below:
Whenever i start anonsurf it will never connect to anything. Firefox, Tor, Bittorrent… it says it’s active when i run the ‘status’ command but when i run ‘myip’ it just shows a blank box. I tried connecting with VPN and without and still nothing. Ping to google doesn’t work either, ‘temporary failure in name resolution’. Please help.

What version of Parrot are you running? 4.7, Security, amd64

What method did you use to install Parrot? USB installer

Configured to multiboot with other systems? no

If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

if you want to find a problem learn how to diagnostic.

first of all:

  • connect to a unfiltered network and look if you have internet and a working name resolution.


if this works go to the next step:

  • run anonsurf from the shell with:

    menuexec /usr/bin/anonsurf start

answers with Y the question about killing apps …
If this starts without errors go to the next step.
If not show us the output.

Now try to ping something …
If it’ s working, open Firefox and go to:

Let me know if this solves your problem!

1 Like

Ok i turned off my firewall (Gufw) and it worked, Anonsurf connects with firewall disabled. But i don’t want to keep my firewall disabled, is there anyway to configure it to allow Anonsurf ports?

1 Like

Oh and i tried your suggestion, ran from the shell and got no errors when killing the apps, said i was successfully browsing through anonymous tunnel (as usual) but still no connection when trying to ping or browse. I’m very new to linux by the way.

oc, open the ports on your firewall for tor.

May i ask which ports you use? i’ve been looking at different articles including Tor FAQ and none of them are really that specific. Or at least not for my specific firewall. I tried opening 80, 443, 9001-9004, 9030-9033 and 9000 outbound on tcp and 9050 inbound on tcp

Still nothing… is it anything to do with my torcc file? Could you post an example of what it should look like if i want to use those ports/what ports i should be using.

I accidentally closed the topic. Thanks Mike but sadly that didn’t work. Rowie, Gufw is basically a GUI for iptables. i took some screenshots but for some reason it won’t let me upload them. Maybe because the thread is now closed.

where is this gufw thing running? i dont have experices with these kind of software firewalls. when the i-net connection is filtered normaly tor connects via tcp 443 (tls socket).

This might be a wild guess, but after trying Anonsurf I lost all internet connection. What I did was turning off the computer, restart computer, Anonsurf STOP and then Anonsurt START. Then I was online again.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.