Anonsurf, TOR, ProtonVPN, openvpn, Windscribe?

Hi very happy to be joining the community! Im using hack the box to learn and setting up dedicated machine for first time. I’m also very new all around so please excuse my mistakes and help me correct any!

— Setting up a new environment on metal, I’ve worked through getting a clean install of parrot security KDE. apt-get upgrade or apt-get update produces lots of errors. Parrot-upgrade worked great! Now I’ve been trying to finalize my browser and IP aliasing services. This is what I’ve encountered. Does anyone have advice or best practices for parrot and using IP aliasing services?

Anonsurf- does not allow TOR browser install must turn off to download and get installed. Gives a possible network or attack error. I would assume this is just a false positive. Just anonsurf not allowing sig verification I’ve attached screenshots. I guess what is intended use of anonsurf? this is so helpful but im still confused AnonSurf - Parrot Documentation Just to hide my IP from other end without any tunneling? I did the following… step 1 new install of parrot. Step 2 turn anonsurf on. step 3 download tor for first time. Produces the attached screenshot. step 4 I added the error to issue on the appropriate github repository.

Tor- works great after turning off anonsurf!

ProtonVPN-download CLI I can only get old community openvpn version to install(which I don’t want), I use the following How to use ProtonVPN on Linux
GUI or new official I cant get installed based off any information I’ve found never able to complete install or it just installs community version even if I follow protons instructions for new version. Very confused. There is a youtube video by legendsploit 8131 im trying to work through my versions with that help. try try again for now.

Windscribe- I can get GUI installed and running but I once running I get hundreds of notifications of broadcast message from systemd=journald@mycomputer update systemd-resolved “busctl” exited with status 1. Also I get
'bell in session". I’ve silenced the notifications but very confused what’s going on its obviously windscribe stops and starts with it.

My preferred goal is to run protonvpn but would really love advice? Also pre-thank you and good karma!!!

  • ParrotOS iso in use: Parrot security KDE

  • Application used for flashing the iso: Balena etcher

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

What? Where did you get this idea?

1 Like

I added some additional information to my original post and a screenshot.

How can AnonSurf not allowing sig verification of an application inside system?
Also there is a screenshot of fixing this problem on Ubuntu, the distro doesn’t have anonsurf

Over my head but Tor FAQ had a really good one about verifying sig with TOR that I found interesting.

How can I verify Tor Browser’s signature?

Digital signature is a process ensuring that a certain package was generated by its developers and has not been tampered with. Below we explain why it is important and how to verify that the Tor Browser you download is the one we have created and has not been modified by some attacker.

Each file on our download page is accompanied by a file labelled “signature” with the same name as the package and the extension “.asc”. These .asc files are OpenPGP signatures. They allow you to verify the file you’ve downloaded is exactly the one that we intended you to get. This will vary by web browser, but generally you can download this file by right-clicking the “signature” link and selecting the “save file as” option.

For example, torbrowser-install-win64-9.0_en-US.exe is accompanied by torbrowser-install-win64-9.0_en-US.exe.asc. These are example file names and will not exactly match the file names that you download.

We now show how you can verify the downloaded file’s digital signature on different operating systems. Please notice that a signature is dated the moment the package has been signed. Therefore every time a new file is uploaded a new signature is generated with a different date. As long as you have verified the signature you should not worry that the reported date may vary.

Installing GnuPG

First of all you need to have GnuPG installed before you can verify signatures.

For Windows users:

If you run Windows, download Gpg4win and run its installer.

In order to verify the signature you will need to type a few commands in windows command-line, cmd.exe.

For macOS users:

If you are using macOS, you can install GPGTools.

In order to verify the signature you will need to type a few commands in the Terminal (under “Applications”).

For GNU/Linux users:

If you are using GNU/Linux, then you probably already have GnuPG in your system, as most GNU/Linux distributions come with it preinstalled.

In order to verify the signature you will need to type a few commands in a terminal window. How to do this will vary depending on your distribution.

Fetching the Tor Developers key

The Tor Browser team signs Tor Browser releases. Import the Tor Browser Developers signing key (0xEF6E286DDA85EA2A4BA7DE684E2C6E8793298290):

<U+202A># gpg --auto-key-locate nodefault,wkd --locate-keys torbrowser@torproject.org

This should show you something like:

gpg: key 4E2C6E8793298290: public key "Tor Browser Developers (signing key) <torbrowser@torproject.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1
pub   rsa4096 2014-12-15 [C] [expires: 2025-07-21]
      EF6E286DDA85EA2A4BA7DE684E2C6E8793298290
uid           [ unknown] Tor Browser Developers (signing key) <torbrowser@torproject.org>
sub   rsa4096 2018-05-26 [S] [expires: 2020-12-19]

If you get an error message, something has gone wrong and you cannot continue until you’ve figured out why this didn’t work. You might be able to import the key using the Workaround (using a public key) section instead.

After importing the key, you can save it to a file (identifying it by its fingerprint here):

gpg --output ./tor.keyring --export 0xEF6E286DDA85EA2A4BA7DE684E2C6E8793298290

This command results in the key being saved to a file found at the path ./tor.keyring, i.e. in the current directory. If ./tor.keyring doesn’t exist after running this command, something has gone wrong and you cannot continue until you’ve figured out why this didn’t work.

Verifying the signature

To verify the signature of the package you downloaded, you will need to download the corresponding “.asc” signature file as well as the installer file itself, and verify it with a command that asks GnuPG to verify the file that you downloaded.

The examples below assume that you downloaded these two files to your “Downloads” folder. Note that these commands use example file names and yours will be different: you will have downloaded a different version than 9.0 and you may not have chosen the English (en-US) version.

For Windows users:

gpgv --keyring .\tor.keyring Downloads\torbrowser-install-win64-9.0_en-US.exe.asc Downloads\torbrowser-install-win64-9.0_en-US.exe

For macOS users:

gpgv --keyring ./tor.keyring ~/Downloads/TorBrowser-9.0-osx64_en-US.dmg.asc ~/Downloads/TorBrowser-9.0-osx64_en-US.dmg

For GNU/Linux users (change 64 to 32 if you have the 32-bit package):

gpgv --keyring ./tor.keyring ~/Downloads/tor-browser-linux64-9.0_en-US.tar.xz.asc ~/Downloads/tor-browser-linux64-9.0_en-US.tar.xz

The result of the command should produce something like this:

gpgv: Signature made 07/08/19 04:03:49 Pacific Daylight Time
gpgv:                using RSA key EB774491D9FF06E2
gpgv: Good signature from "Tor Browser Developers (signing key) <torbrowser@torproject.org>"

If you get error messages containing ‘No such file or directory’, either something went wrong with one of the previous steps, or you forgot that these commands use example file names and yours will be a little different.

Workaround (using a public key)

If you encounter errors you cannot fix, feel free to download and use this public key instead. Alternatively, you may use the following command:

<U+202A># curl -s https://openpgpkey.torproject.org/.well-known/openpgpkey/torproject.org/hu/kounek7zrdx745qydx6p59t9mqjpuhdf |gpg --import -

Tor Browser Developers key is also available on keys.openpgp.org and can be downloaded from https://keys.openpgp.org/vks/v1/by-fingerprint/EF6E286DDA85EA2A4BA7DE684E2C6E8793298290. If you’re using MacOS or GNU/Linux, the key can also be fetched by running the following command:
$ gpg --keyserver keys.openpgp.org --search-keys torbrowser@torproject.org

You may also want to learn more about GnuPG.

Evo :slight_smile:
Can you assist with latest Anonsurf install?

A challenge to do.

The instructions should be revised - even though this request upsets DarkKnight. AnonSurf - Parrot Documentation Trying to figure out. Thank you

sudo apt install nim
nimble install gintro
> lots of lines say dependencies are NOT loading
1 Like


This was my results from following doc first try.

im trying to get following working


> sudo apt install nim


> nimble install gintro

Then you can download the anonsurf source:… ie i assume i should do following?

sudo git clone GitHub - ParrotSec/anonsurf: parrot anonymous mode

the photo pictured in documentation is partial screenshot of the makefile within anonsurf download i try following along but get lots of results i dont understand. but yeah it seems like this whole install should work fine if getting trough makefile is possible im stuck here

cd anonsurf/
make build-parrot
make install

Evo :slight_smile:
Thank you for looking in to this.

You should not be stuck. Wish others would try to revise. What version is currently on your computer?

We want Anonsurf 3.2 GUI interface with random MAC. That github is 3.1.9 not 3.2 anonsurf. Currently , 3.1.9 is installed . But NOT the GUI interface which says 3.1.8.

Guess we’re the only 2 users who can’t update to 3.2.

The Parrot Doc instructions do not state ‘anon@desktop’. Will keep trying.

When possible, appreciate you posting accurate steps to upgrade to 3.2 Anonsurf.
Grazzi

Well this might be an assumption on my part but i think we might have they already most up to date versions, i say this because the code in github is the 3.1.9 maybe the 3.2 will get pushed to github soon for us to use… idk lets keep researching I’m trying to get all my IP aliasing services running via this threads help and any others.

anon@desktop is my name my computer temporary names ie… “yourname” “yourcomputer” trying this

whoami

Getting same results as your cap. Why did they post the 3.2 ver instructions if not working?

Also, adding bridges to anonsurf would be good. Plus, clone MAC address.

Guys. Nest (GitLab) is our main instance. The instructions work, maybe you haven’t seen the 3.2.0 branch? On GitLab it is easy to select a branch: Files · 3.2.0 · packages / tools / anonsurf · GitLab

Maybe the 3.2 flag is missing @dmknght, but the code is the new one.

1 Like

Thank you this helped so much. Learning alot by setting this up thx so close now

i feel like I’m successful in process till

make build-parrot

i then run

make install

results are

┌─[anon@anon-virtualbox]─[~/Desktop/anonsurf]
└──╼ $make install

Create all folders

mkdir -p /etc/anonsurf/
mkdir -p /usr/lib/anonsurf/
mkdir -p /usr/bin/
mkdir -p /usr/share/applications/
mkdir -p /lib/systemd/system/

Copy binaries to system

cp bin/anonsurf /usr/bin/anonsurf
cp: cannot create regular file ‘/usr/bin/anonsurf’: Permission denied
make: *** [Makefile:47: install] Error 1

ive attempted

mkdir -p $(DESTDIR)/etc/anonsurf/
mkdir -p $(DESTDIR)/usr/lib/anonsurf/
mkdir -p $(DESTDIR)/usr/bin/
mkdir -p $(DESTDIR)/usr/share/applications/
mkdir -p $(DESTDIR)/lib/systemd/system/

should i be replacing (DESTDIR) with ??? with where i put 3.2 clone ie… desktop/anosurf, or just leaving $(DESTDIR) and running results CD into anonsurf folder dosent produce any results sorry for so many beginner ???'s

Do you see that it says “permission denied”? You should probably use sudo because the command cp is copying the binary file to a folder with all the system executable files (and therefore it needs permissions to do so). In any case the binary file was created, so the building phase was successful as I said above. There is no need for a video. First study how to use a GNU/Linux system before moving on to this topics.

1 Like

Thank you… sometimes i feel so silly with small mistakes! Basic ideas will probably resolve most my user mistakes within my own process before getting this running. Thanks for advice.

I’m using Parrot security OS, one of my friend using Ubuntu , he asked me about How to install anonsurf in Ubuntu. I have posted in parrot security os forum nearly 11 hours but till now there is no further response from Forum side. @danterolle . Very bad experience.

Hello. I already answered your friend. There is in the documentation a way to install Anonsurf. Follow it. Help him too, and learn how to use a GNU/Linux system. I want to point out that we are not just here to answer your questions. And if you need help, urgently, join the Telegram group.

I want to point out that we are not just here to answer your questions → Why is forum for, not answering users questions.

Where I can found Telegram LInk @danterolle

That sentence meant we are here for not just answering questions, but doing other things too. I guess you and your friend got a hard time reading our documentations, as well as other topics?

Thanks @dmknght for explaining it. We do other important things besides helping users in the forum.

In the documentation you will find all the references: Community & Social - Parrot Documentation