Anonymous mode start everytime

parrot

(fapencio404) #1

the anonymous mode starts whenever I start the chrome browser,I can not navigate since it always starts to run.


(Lorenzo "Palinuro" Faletra) #2

i need more details as anonsurf does not have an autostart function


(fapencio404) #3

when I start the browser and enter (for example) youtube, the site does not load, even taking 8.8.8.8 of dns and having internet access (pinging 8.8.8.8), when I verify what is my public ip, gives me an ip of the TOR network, the site starts to charge when I turn off the annonsurf mode. but I do not start the annonsurf mode ever.


(Akito Kitsune) #4

What do you do before starting the browser? How did you customize your installation?


#5

dont touch your dns, once a fresh install just load chrome first then
goto Applications/Anonsurf Start…click NO when it asks you to kill processes,
once the terminal disappears
goto https://whatismyipaddress.com/

thats how it works with firefox


(Lorenzo "Palinuro" Faletra) #6

i have an idea

i need you to boot your computer and run the following commands WITHOUT disabling anonsurf

ls -l /etc/resolv.conf

cat /etc/resolv.conf

ifconfig

ifconfig -a

apt policy resolvconf

service resolvconf status

run the following commands and put here the output of each of them

i think you have a dns misconfiguration, while the stop script of anonsurf is known to trigger a dns reconfiguration to the latest working state


#7

I think I have the same problem, when I start anon surf (and say no or yes to terminating applications) my dns stops resolving, here are the outputs:

ls -l /etc/resolv.conf =

-rw-r–r-- 1 root root 71 Feb 12 17:51 /etc/resolv.conf

cat /etc/resolv.conf =

nameserver 127.0.0.1
nameserver 92.222.97.145
nameserver 192.99.85.244

ifconfig =

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.5.2 netmask 255.255.255.0 broadcast 192.168.5.255
ether 3c:97:0e:96:b6:b3 txqueuelen 1000 (Ethernet)
RX packets 47679 bytes 57996241 (55.3 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 37501 bytes 6089063 (5.8 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 20 memory 0xf3a00000-f3a20000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
loop txqueuelen 1000 (Local Loopback)
RX packets 7342 bytes 4353948 (4.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 7342 bytes 4353948 (4.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500
inet 10.186.35.54 netmask 255.255.255.255 destination 10.186.35.53
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 100 (UNSPEC)
RX packets 589 bytes 208447 (203.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 729 bytes 101082 (98.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ifconfig -a =

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.5.2 netmask 255.255.255.0 broadcast 192.168.5.255
ether 3c:97:0e:96:b6:b3 txqueuelen 1000 (Ethernet)
RX packets 47686 bytes 57997898 (55.3 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 37507 bytes 6090593 (5.8 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 20 memory 0xf3a00000-f3a20000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
loop txqueuelen 1000 (Local Loopback)
RX packets 7350 bytes 4354644 (4.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 7350 bytes 4354644 (4.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1500
inet 10.186.35.54 netmask 255.255.255.255 destination 10.186.35.53
unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 txqueuelen 100 (UNSPEC)
RX packets 589 bytes 208447 (203.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 734 bytes 101917 (99.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4098<BROADCAST,MULTICAST> mtu 1500
ether 22:a1:a1:35:59:95 txqueuelen 1000 (Ethernet)
RX packets 4347 bytes 4942887 (4.7 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 2882 bytes 753724 (736.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

apt policy resolvconf =

resolvconf:
Installed: 1.79
Candidate: 1.79
Version table:
*** 1.79 1001
1001 http://deb.parrotsec.org/parrot stable/main amd64 Packages
100 /var/lib/dpkg/status

service resolvconf status
● resolvconf.service - Nameserver information manager
Loaded: loaded (/lib/systemd/system/resolvconf.service; enabled; vendor preset: enabled)
Active: active (exited) since Mon 2018-02-12 17:51:14 AWST; 3min 44s ago
Docs: man:resolvconf(8)
Process: 14344 ExecStop=/sbin/resolvconf --disable-updates (code=exited, status=0/SUCCESS)
Process: 14409 ExecStart=/sbin/resolvconf --enable-updates (code=exited, status=0/SUCCESS)
Process: 14408 ExecStartPre=/bin/touch /run/resolvconf/postponed-update (code=exited, status=0/SUCCESS
Process: 14407 ExecStartPre=/bin/mkdir -p /run/resolvconf/interface (code=exited, status=0/SUCCESS)
Main PID: 14409 (code=exited, status=0/SUCCESS)


(Jorge Carretero) #8

Hi everyone.-

I also want to start Anonsurf at system startup. What i do is the following.-
1 Created a bash file and in it i added the anonsurf start command
2 as root i edited the ~/.profile file with vi editor
3 in that file i added ./nameofmyscipt.sh

The script executes correctly at boot but i lost my connection, i know i have the correct idea but dont know whats happening here, any ideas?

My question is how do i execute anonsurf from my profile file ?
The script has only anonsurf start on it

@palinuro hey i have a idea !!! why dont we modify Anonsurf to make it more “automatic” no prompts, that way maybe it can run correctly from boot


closed #9