Another Day, Another Error.

Using Mate. Latest rolling.

Got a pupup for update. I did update.

And now im getting a bunch of errors.

└──╼ $sudo parrot-upgrade
[sudo] password for user: 
Ign:1 parrot InRelease
Err:2 parrot Release
  Certificate verification failed: The certificate is NOT trusted. The revocation or OCSP data are old and have been superseded. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 443]
Reading package lists... Done
E: The repository ' parrot Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
failed to update index lists
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
└──╼ $

I did run apt-get update and it showed me the following warning :

└──╼ $sudo apt-get update
Get:1 parrot InRelease [14.4 kB]
E: Repository ' parrot InRelease' changed its 'Codename' value from 'parrot' to 'rolling'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N] y

Not sure why parrot have been rushing/pushing buggy updates in past few months. Even the latest 4.7 got issues where users cant even get past the grub. Similar to the previous issues in 4.6 and 4.5 where users were either stuck on grub or on login screen

Another case of poor pre-testing and rushing to push unstable updates that break devices :frowning:

This warning showed because Palinuro changed code name in release repository. It has nothing to do with initramfs error which is from installer script and it doesn’t break anything in your system.


I know. I was reffering to the several buggy updates in past few months reported on the community.

We are working on it (bugs). We are focusing on LTS version and Rolling version which was planed months ago so we can’t avoid bugs.


same here! test-brunch deployed like Cloudflare? :wink:

1 Like

How to get rid of this issue

Hello @Sachin_Murpana

i tired this and it seems it worked for me.

sudo apt-get update

if you get promt for something, select y aka (yes)

then to complete the all the updates

sudo parrot-upgrade

a little more info: after upgrade, your config in source list will be changed (it should points to rolling edition). And everything will be okay.

1 Like

Quick question.
Does this has anything to do with tor browser (probably not) but i havent used Tor browser in a couple of weeks. Today i launched the browser, got an error. Reinstalled it, still got the same error.

No it could be error from tor itself or lib or something. You can read error log and find the error (it could be firejail problem maybe). Try run tor without firejail

Thanks :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.