AP stopped working, wifi named wlxxxxxxxxx.

Since 4.8 update my AP stopped working with airgeddon, i beleive it has to do with hostapd.
Also, my wifi adapters are being named wlxxxxxxxxxxxx. i beleaive ive found the solution for wlxxxxxxxxxxxx naming, but cant figure out how to resolve the AP. Ive tried 2 wifi adapters, both worked before update. tp-link and the panda pau09. I’m stuck and could use some help.

Hey there! We’d love to help but we need more information. Please fill out the support form in accordance with our support guidelines so we can better assist you.

Sorry first time using support page, Ive always resolved with google.

 What version of Parrot are you running?
PRETTY_NAME="Parrot GNU/Linux 4.7"
NAME="Parrot GNU/Linux"

What method did you use to install Parrot?
Debian Standard, usb with persisence

Configured to multiboot with other systems?

If there are any error messages or relevant logs, post them below:

wlx9cefd5fcd71d: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether ee:70:3c:da:65:cc txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

could not read interface wlan0 flags: no such device
nl80211: Driver does not support auth/assoc or connect commands
nl80211: deinti iframe=wlan0 disabled_11b_rate=0
could not read interface wlan0 flags: no such device
nl80211 driver intialization failed
wlan0: interface state UNINITIALIED -> DISABLED
hostapd_free_hapd_data: Interface wlan0 wasnt started.

I hope this is in the format and at least some of the info you need to help me out.

Thanks for completing the form I have relisted your post :slight_smile:

looking into your problem and will get back to you as soon as there is an answer + fix. As Parrot is Debian based there was a known hostapd/NetworkManager update and it may be related to a bug in that update.

Did you update right before the problem?

A user posted a solution yesterday here:

Let us know if it works for you

Everything worked great till I update and dist-upgrade. Then things went wrong. I will check if this solution works for me in the morning.

Thanks for the help!!!

1 Like

You’re welcome! :slight_smile:


Wifi is working now, but still no ap on airgeddon. Worked before sudo parrot-upgrade.

Ok, so i checked AP on my HP laptop and AP works and it works great, but on cheap RCA tablet ( that worked before update) doesnt work now. How would I go about trouble shooting this?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.