apps wont open file containing folder


(comsense comsense) #1

Hi, wont
for example:

Chrome
File has been downloaded, clicking “Show in folder” - Nothings happens

Qbittorent / Deluge
The same story. Once file has finished downloading, I try to open the file containing folder through the app

and many other applications that have an option to open a file containing folder.
Does anyone know how to fix it? it is one of main function of any OS…

I’m running Parrot GNU/Linux version 4.4 on my pendrive with persistence


#2

it might be because all the apps you said have firejail profiles, so it might be why. you can still open your file manager and find the files you downloaded, right ?


(comsense comsense) #3

Yes, I can. But would be the way much easier to do it from within the app itself.


#4

i understand, but that would be less secure, because if your internet browser was to be compromised, an attacker could get all the data from your system, that’s why it runs sandboxed.

you can alway run you applications without firejail but that is not recommended.

an alternative though, is to create a folder inside your “home” directory exclusively for download, because there are places where you browser can see the files. for example the “desktop” folder inside “home” is readable by your sandboxed applications


(comsense comsense) #5

Thanks for reply hbgjjmya.
Just checked and it looks like my chrome browser doesn’t allow me to change Downloads location. There are visible folders but it automaticly redirects me to the defauld downloads folder wherever i click. I’ve created a folder inside home directory like you said but with the same result… Sooo annoying. How do I run an app without firejail?


(Nico Paul) #6

if you use firefox (more secure anyway) you dont open but you save the file and it saves to downloads folder i dont think i recall haviing to change it to allow this, thats why there is a downloads folder in /home/USER/Downloads