Apt error 404 on install and upgrade

  1. Your Parrot information:
    Linux parrot 5.4.0-2parrot1-amd64 #1 SMP Parrot 5.4.8-2parrot1 (2020-01-12) x86_64 GNU/LinuxHome

  2. How did you get this error? Are there any steps to procedure it?

  3. I originally broke my audio in an attempt to fix glitchy sound in wine. After that everything worked fine for about a month (except for audio obviously), apt was able to install and update packages, until

  4. I ran the following command:
    sudo apt remove --purge alsa-firmware-loaders alsa-oss alsa-tools alsa-tools-gui alsa-topology-conf alsa-ucm-conf alsa-utils alsamixergui pulseaudio
    and rebooted. After reboot the problem appeared.
    I don’t know any way to reproduce the error.

  5. Error log or screenshot
    Apt output is massive, so i pasted it here: https://pastebin.com/21AmJhGr
    I don’t think it’s necessary to translate everything since my apt isn’t any different from your apt, but if someone asks, i’ll translate everything and make a new paste.
    I didn’t include full output since there are a lot of packages, but for each one it is all the same. If i wait for apt to process every package it just says “Hey, you have errors, how about --fix-missing?”.
    Also, it says “Ign:” on every package that doesn’t give error 404.

  6. If you have any idea or suggestion about this issue please tell us
    I don’t think that i know what could cause the problem, i don’t really do much to this system, just work, develop my own projects and play games from time to time.

I want to mention that there are a lot of similar posts across the internet, even here i found a couple, ex. this one: Errors when using apt-get on terminal
Even though they look very similar to my issue, nothing that worked for all those people worked for me. I tried apt clean, apt update && apt full-upgrade, apt dist-upgrade, -f install, --fix-missing, and i still get error 404 every time i try upgrade or install. Synaptic also did nothing and from its output i could see all the same errors.
Rebooting didn’t help either.
The only repos i currently have in my sources.list.d are: steam.list (auto generated by steam), google-chrome.list (auto generated by chrome) and parrot.list with one addition - MIT parrot mirror. Still doesn’t work.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.