Arachni: gems bundle problem


(fly_with_parrot) #1

sysinfo:

Linux parrot 4.18.0-parrot8-amd64 #1 SMP Parrot 4.18.6-1parrot8 (2018-09-07) x86_64 GNU/Linux

Another problem found_ this time Arachni web vulnerabilty scanner tool._ Gems bundle

Could not find rake-11.3.0 in any of the sources
Run bundle install to install missing gems

$bundle install
–>>>>>Could not locate Gemfile

but When i am using this command

[email protected]$locate gems

/usr/lib/dradis/engines/dradis-api/dradis-api.gemspec
/usr/lib/dradis/ruby/2.5.0/gems
/usr/lib/dradis/ruby/2.5.0/bundler/gems
/usr/lib/dradis/ruby/2.5.0/bundler/gems
…what is happening Any Idea or solution


(Shawn Duffy) #2

I also tried purging the copy that came with Parrot 4.18.0-parrot10-amd64 and used a copy from Github.
The issues are the same.

I was able to set the gemfile:
$bundle install --gemfile /usr/Downloads/arachni/Gemfile

I was not able to get past the outdated gem msgpack-0.7.0:
Installing msgpack 0.7.0 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/tmp/bundler20181125-63989-1fogbv0msgpack-0.7.0/gems/msgpack-0.7.0/ext/msgpack
/usr/bin/ruby2.5 -r ./siteconf20181125-63989-1t5yard.rb extconf.rb
checking for ruby/st.h… yes
checking for st.h… yes
checking for rb_str_replace() in ruby.h… yes
checking for rb_intern_str() in ruby.h… yes
checking for rb_sym2str() in ruby.h… yes
checking for rb_str_intern() in ruby.h… yes
checking for rb_block_lambda() in ruby.h… yes
checking for rb_hash_dup() in ruby.h… yes
checking for rb_hash_clear() in ruby.h… yes
creating Makefile

current directory: /tmp/bundler20181125-63989-1fogbv0msgpack-0.7.0/gems/msgpack-0.7.0/ext/msgpack
make “DESTDIR=” clean

current directory: /tmp/bundler20181125-63989-1fogbv0msgpack-0.7.0/gems/msgpack-0.7.0/ext/msgpack
make “DESTDIR=”
compiling buffer.c
compiling buffer_class.c
compiling core_ext.c
core_ext.c: In function ‘MessagePack_core_ext_module_init’:
core_ext.c:135:22: error: ‘rb_cFixnum’ undeclared (first use in this function); did you mean
‘rb_isalnum’?
rb_define_method(rb_cFixnum, “to_msgpack”, Fixnum_to_msgpack, -1);
^~~~~~~~~~
rb_isalnum
core_ext.c:135:22: note: each undeclared identifier is reported only once for each function it
appears in
core_ext.c:136:22: error: ‘rb_cBignum’ undeclared (first use in this function); did you mean
‘rb_isalnum’?
rb_define_method(rb_cBignum, “to_msgpack”, Bignum_to_msgpack, -1);
^~~~~~~~~~
rb_isalnum
make: *** [Makefile:243: core_ext.o] Error 1

make failed, exit code 2

Gem files will remain installed in
/tmp/bundler20181125-63989-1fogbv0msgpack-0.7.0/gems/msgpack-0.7.0 for inspection.
Results logged to
/tmp/bundler20181125-63989-1fogbv0msgpack-0.7.0/extensions/x86_64-linux/2.5.0/msgpack-0.7.0/gem_make.out

An error occurred while installing msgpack (0.7.0), and Bundler cannot continue.
Make sure that gem install msgpack -v '0.7.0' --source 'https://rubygems.org/' succeeds before
bundling.

In Gemfile:
arachni was resolved to 1.5.1, which depends on
msgpack

Any ideas how to get past this error?
I’ve tried to force using the newer msgpack-1.2.4, but after fixing the bundle install, then arachni wouldn’t work. I have a clean copy and am back to this same error above.

Thanks,
ShawnD