Armitage failed to start

Briefly describe your issue below:
After my recent upgrade, I switched my account to a user where in I summitted all the privilege of the administrative user to and added it to the sudo group, but after all this armitage fails to start when ever I attempt to, I couldn’t switch to default user, I delete it, even login in as root it won’t start, I use the lines:
service postgresql start
msfstart-armitage

It tries connecting to the port 55553 and localhost 127.0.0.1 after few seconds giving sort of a feedback:
“Could not connect to the database.”

“Kali Linux 1.x users, try:”
“service postgresql start”
“service metasploit start”
“service metasploit stop”

“Kali Linux 2.x users, try:”
“/etc/init.d/postgresql start”

“Connection refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.”

I tried everything and all I can to get this working, I don't want to reinstall the system please help.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Linux parrot 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard
Configured to multiboot with other systems? (yes / no) no

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Try start metasploit first

Still not working

Msfrpcd has to be running as well I think…you know armitage is considered rather old software so it may not work anymore.

/usr/share/metasploit-framework/vendor/bundle/ruby/2.7.0/gems/actionpack-5.2.4.3/lib/action_dispatch/middleware/stack.rb:37: warning: Using the last argument as keyword parameters is deprecated; maybe ** should be added to the call
/usr/share/metasploit-framework/vendor/bundle/ruby/2.7.0/gems/actionpack-5.2.4.3/lib/action_dispatch/middleware/static.rb:111: warning: The called method `initialize’ is defined here
[-] Error: a password must be specified (-P)

That’s the output of the command, still not working

I really don’t want to reinstall , I really need help about this

Start postgresql service
make sure db has been initialized “msfdb init”
start armitage, the msfrpc server will start itself. If rpc server is already started it should just be killed before starting armitage so it will be done for you, easiest that way.

Still didn’t start

I hoped there was a solution at the end. I am also having a similar problem here.
Can anyone help please?