[AUDIO ISSUE] Speaker undetected

Hi everyone,

I am sorry to bother you guys but i tried everything i found on the net.
I can find my audio cards (chipset plus nvidia card) using commands but not able to use it (appears muted).

Here’s my release :
DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.10
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION=“Parrot 4.10”
PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.10”
VERSION_ID=“4.10”
HOME_URL=“https://www.parrotsec.org/
SUPPORT_URL=“https://community.parrotsec.org/
BUG_REPORT_URL=“https://community.parrotsec.org/

And my kernel version :
Linux aymeric-tufgamingfx705gd 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

Here’s my audio material :
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)

I tried installing nvidia proprietary driver which worked but did not solve the audio problem.

Here’s a screenshot :

“Eteint” means off.

Here’s the full HW probe, with installed drivers :

I’d definitely appreciate your help!

Aymeric

have you selected your speaker as output in sound preferences?
give it a try

  1. Right click the volume icon in the upper menu
  2. click sound preferences
  3. click output tab
    and choose from there and see if that works

Thanks for you answer.
In that menu there’s only that “Off” option available.
Using “pavucontrol” they offer me to choose outputs, but it’s all HDMI (???), tried anyway, not working obviously.

image
select your hardware and see if that works
if speaker is detected, it should not have been a big deal

I don’t have that menu on my system but there’s nowhere i can do that. If you look at the screen in my topic, i can’t get it to make an output, it only appears to be “off”.

ah i can’t understand the screenshot
different language

Yes and it’s okay.
It’s in the audio settings, only card shown is the actual Nvidia card i got but the only output i can choose is “off” and it appears muted. Can’t get to change that, can’t play any sound

Check /var/log/messages and see if you are loading your firmware. I installed ParrotOS today for the first time and ran across the same problem. When I checked /var/log/messages, there was the error that it could not find the firmware for the audio device. I posted a question about how to find and install the firmware, but it’s awaiting moderation…

Hey! Thanks for that answer. You are correct, my Intel integrated chipset failed to load.

Oct 20 09:02:21 aymeric-tufgamingfx705gd kernel: [ 5.800301] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cfl.ri failed with error -2

Here is the complete log :

[    6.956173] sof-audio-pci 0000:00:1f.3: firmware: failed to load intel/sof/sof-cfl.ri (-2)
[    6.956176] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cfl.ri failed with error -2
[    6.956179] sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cfl.ri failed err: -2
[    6.956181] sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
[    6.956709] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2

DUDE !

Just fixed my problem. Here’s what i’ve done :

  1. Installed alsa-ucm-conf
  2. Created file /etc/modprobe.d/dsp-fix.conf (did not exist, if it does, just edit it)
  3. In the previous file, wrote ’options snd-intel-dspcfg dsp_driver=1
  4. reboot => AUDIO WORKS! YES, FINALLY!
1 Like