Audio not working after reinstalling pulseaudio

Briefly describe your issue below:
I recently dual booted Parrot with Windows 10 and everything worked fine except for the microphone. To fix that, I tried this:
rm -r ~/.config/pulse
rm -r ~/.pulse
sudo apt-get purge pulseaudio pavucontrol
sudo apt-get install pulseaudio pavucontrol
When I restarted my machine, none of the audio buttons worked (volume up/down and microphone mute). I even tried firecfg --fix-sound.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Linux parrot 5.2.0-2parrot1-amd64 #1 SMP Parrot 5.2.7-2parrot1 (2019-08-12) x86_64 GNU/Linux
KDE version

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian Standard

Configured to multiboot with other systems? (yes / no)
Yes (with Windows 10)

If there are any similar issues or solutions, link to them below:
None I can find so far.

If there are any error messages or relevant logs, post them below:
This is from /var/lod/syslog

Aug 21 15:58:55 parrot systemd[1039]: pulseaudio.socket: Succeeded.
Aug 21 16:02:07 parrot pulseaudio[1412]: E: [pulseaudio] module.c: Module “module-device-manager” should be loaded once at most. Refusing to load.

dmesg says nothing about pulseaudio

[Update / Solution]
I ended up fixing this issue so here’s an update in case it helps someone.

I checked /var/log/apt/history.log and it turns out sudo apt-get purge pulseaudio actually removed the following:

  • gqrx
  • plasma-pa
  • pulseaudio
  • pulseaudio-module-bluetooth

apt-get purge isn’t even supposed to remove dependencies so I have no idea as to why this happened. I reinstalled all the packages and everything worked perfectly. Hope this helps!

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.