AWUS036ACH VM Problem

Dear all, I was giving Parrot a try but just can’t get the AWUS036ACH USB adapter work in VMWare.
Just installed Parrot normally and updated to the newest packages.
Even though I have some Linux experience, I just seem to miss something to get this done. Any help is appreciated.

VMWare is configured to use the USB 3.0 controller.
The adapter is connected by USB 3.0 directly on the mainboard.
It just works fine with Windows. It also works fine when I boot up Parrot into the live environment directly on the hardware (Not in VMWare).

I installed the aircrack drivers

and also tried this one

But all I get after passing the USB device through is this:

$ dmesg

[ 2078.224125] RTW: rtw_wdev_free(wdev=00000000385028b1)
[ 2078.224126] RTW: rtw_wiphy_free(phy15)
[ 2078.224131] RTW: rtw_usb_primary_adapter_deinit((null))
[ 2078.224131] RTW: rtw_dev_unload: bup==_FALSE
[ 2078.224134] RTW: +r871xu_dev_remove, hw_init_completed=0
[ 2078.224198] RTW: WARN free_recv_skb_queue not empty, 8
[ 2078.224207] RTW: usb attached..., try to reset usb device
[ 2078.540638] usb 3-2: reset high-speed USB device number 20 using xhci_hcd
[ 2083.972707] usb 3-2: device descriptor read/64, error -110
[ 2099.844832] usb 3-2: device descriptor read/64, error -110
[ 2100.264622] usb 3-2: reset high-speed USB device number 20 using xhci_hcd

$ lsusb
Bus 003 Device 000: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter

$ lsmod

cfg80211 823296 1 88XXau

It jsut drives me crazy. Any ideas?

Thank you in advance


Alright for the records for anyone who has the same problem.
It could be related to Gigabyte Motherboards like mine.

This could solve the problem:

Unfortunately the IOMMU setting is missing on my GA-Z97X-Gaming 3 board so I will have to wait for feedback from Gigabyte or just replace this sh*t board.

You could try building a previos version of the driver, that is the best workaround for the devices that have problems with 88XXau driver for rtl8812au.

Hello muroga, thank you very much for your reply. Unfortunately I have tried so many drivers but still can’t make this work on my desktop PC.
But the adapter works in a VM on my old ThinkPad with multiple drivers. (Even though airgeddon gives an error in the WPS menu)
This really seems to be an issue with my Gigabyte board in combination with USB 3 and VM.

I also tried booting the kernel with intel_iommu=off and on but still no luck.

I think I will just give up this case.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.