AYUDA: "apt-get update" error!

parrotsec
update
parrot
español

(camilo) #1

¡Hola a todos!
Me gustaría saber si lo que tengo a continuación se puede resolver.

Hoy 19 de Agosto cuando introduje el comando en mí terminal “apt-get update” me salio el siguiente error:

(appstreamcli:17885): GLib-CRITICAL **: 16:33:36.116: g_variant_builder_end: assertion ‘!GVSB(builder)->uniform_item_types || GVSB(builder)->prev_item_type != NULL || g_variant_type_is_definite (GVSB(builder)->type)’ failed

(appstreamcli:17885): GLib-CRITICAL **: 16:33:36.116: g_variant_new_variant: assertion ‘value != NULL’ failed

**(appstreamcli:17885): GLib-ERROR : 16:33:36.116: g_variant_new_parsed: 11-13:invalid GVariant format string
Trace/breakpoint trap
Leyendo lista de paquetes… Hecho
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi’
E: Sub-process returned an error code

¿Qué es este error?
SI alguien sabe, por favor, deje su comentario.
Gracias por leer.


#2

Prueba con el comando sudo para ejecutar el apt-get update co privilegios root:

1.- $sudo apt-get update.

Si todo va bien:
2.- $sudo apt-get upgrade.

Se actualiza el sistema, puede suceder que si salen errores como por ejemplo, que el promt indique que tienes el cd de instalacion como fuente de instalacion; ya toca editar el archivo: “/etc/apt/sources.list” con el editor Geany por ejemplo con privilegios root (en terminal invocar: $sudo geany). comentar el parrafo que tiene sobre el cd con: “#” y guardar el archivo.

Repetir el proceso de actualizacion.