Bettercap is running on background.


(Elliot Anderson) #1

When i checked which of port is currently used for listening using command

netstat -tulpn | grep LISTEN

I found that bettercap is running on background and is actively listening. I tried to remove the same using kill command but it comes back.


(Matt) #2

Yep it the same for me. If you use,

ps -eF | grep bettercap

There you should be able to see api.rest on, thats what makes it listen on 8081. I havent found out why yet, it changed since the newest version.


(Elliot Anderson) #3

Thanks for reply, i had to uninstall bettercap since other method to stop it was not working.


(Matt) #4

So bettercap has added a new service that starts on boot to handle API requests (https://www.bettercap.org/modules/core/api.rest/).
You can see the service here https://github.com/bettercap/bettercap/blob/master/bettercap.service

You can stop it using

sudo service bettercap stop

You can prevent it starting at boot using

sudo systemctl disable bettercap

(Elliot Anderson) #5

That is the answer i was looking for. Thanks for making it easy.