Bfgminer


#1

I need to install bfgminer because cgminer no longer supports GPUs. But, when I try I get:

The following packages have unmet dependencies:
bfgminer : Depends: libblkmaker-0.1-6 (>= 0.5.3) but it is not installable
Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
E: Unable to correct problems, you have held broken packages.

wat do? I assume it isn’t safe to manually download the packages from the debian website and install them?

Any suggestions for other applications for GPU mining, or how to fix this problem?

thanks


(Lorenzo "Palinuro" Faletra) #2

this problem have to be fixed in debian testing, not in parrot

https://packages.debian.org/source/bfgminer


#3

Oh, sh*t. Debian (Stretch) doesn’t even have the package. Thanks. I didn’t even notice that. I’ll have to go complain on the Debian support forums


#4

If anyone comes across this, I actually got bfgminer to work by going to github and installing from there. I currently haven’t gotten it to display core temps, but according to the readme this is a common error on linux systems. i’ve only tested CPU and GPU, but it seems to work fine. Hashrate seems a little low, but its hard to find comparisons since nobody GPU mines anymore. Hashcat benchmarks SHA256 at over 8 Gh/s, but it looks like I’m only getting 1-3Gh/s.

If I contine to use bfgminer when/if I get an ASIC rig, I’ll check back into to let everyone know how it goes.