BIOS entry / Encrypt passphrase for Parrot Sec disappeared

Hello to the Parrot forum!

I am trying to install the latest Parrot Sec version (4.11) on a second laptop I have, and the installation went well: it was actually a re-install as the first attempt ended up with root being locked for some reason (tried to publish this ticket on Saturday, but I have have missed something before validating it :-D).

The (re) installation went smoothly and I have chosen the option to encrypt the disk, and this worked from the first time: the passphrase was requested at boot, then I got the grub menu for the dual boot laptop (Win 10 + Parrot Sec).

However, I then later tried another Linux distro from a live usb (Mint Linux) thinking to add a non-sec focused distro too, and then impossible to boot on Parrot or even find the grub, and no more passphrase requests for the encrypted boot.

I have explored different things, to find the Parrot boot in BIOS, via Windows command line (mounting & exploring system partition, use of bcdedit.exe, etc.) in vain.

Could you please help with this issue?

More generally, are there some recommendations as to the sequence / steps to have Parrot + another Linux distro installed aside Win 10 (btw it looks my issue may have something in common with this post:
ParrotOS Deletes Boot entries from BIOS with Fedora Distros)

Many thanks!

Alex

– Please Write here your help request –


  • ParrotOS iso in use:
    Parrot Sec 4.11

  • Application used for flashing the iso:
    Rufus (latest version)

  • Logs/Terminal output (use pastebin or similar services):
    Can’t provide any logs or screenshots, as I can’t boot into Parrot anymore.

I can provide however info that would be needed to see the situation about boot, grub etc. please just specify what would be useful

  • Screenshots:

Hello to Parrot forum,

Nessun risponda ? :wink:

I would really like to recover this install, as I could use it for a number of days without any issue. This is a bit puzzling me, and would like to resolve this technically (wiping everything is of course feasible, but that’s not the way I’d like to go forward on this topic).

Cheers,

Alex

Go to bootloader using f12 key on startup (f key depends on laptop manufacturer)
or if you’ve installed on the same partition or by erasing, then you might also removed the os which now tends to be not visible.