Bitmask VPN fails to make connection

Briefly describe your issue below:

Hello guys,

Could you please assist me in running the Bitmask VPN application on Parrot OS. I installed it following the debian instructions from https://bitmask.net/en/install/linux

I successfully open the program and log in my Rise up servers account but when I click Turn on the VPN, it constantly reconnects and fails to make connection.

When I run the program from the terminal as normal user, I receive below log when I try to Turn on the VPN connection:

[+] launching bitmaskd...
[+] registering python<->js bridge
js: Warning: Accessing PropTypes via the main React package is deprecated, and will be removed in  React v16.0. Use the latest available v15.* prop-types package from npm instead. For info on usage, compatibility, migration and more, see https://fb.me/prop-types-docs
js: Warning: Accessing createClass via the main React package is deprecated, and will be removed in React v16.0. Use a plain JavaScript class instead. If you're not yet ready to migrate, create-react-class v15.* is available on npm as a temporary, drop-in replacement. For more info see https://fb.me/react-create-class
ERROR:tornado.application:Exception in callback <functools.partial object at 0x7ff021ada5d0>
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/tornado/ioloop.py", line 758, in _run_callback
    ret = callback()
  File "/usr/lib/python2.7/dist-packages/tornado/stack_context.py", line 300, in null_wrapper
    return fn(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/leap/common/events/client.py", line 411, in <lambda>
    self._loop.add_callback(lambda: callback(event, *content))
  File "/usr/lib/python2.7/dist-packages/leap/bitmask/gui/systray.py", line 101, in _handle_vpn_event
    self.setVPNStatus(status.lower())
AttributeError: 'NoneType' object has no attribute 'lower'
js: Uncaught (in promise) 'NoneType' object has no attribute 'lower'

I also tried to login as root in the terminal and to run the program as root - it doesnt open at all and I receive the below errors:

[+] launching bitmaskd...
QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0
Qt: Session management error: None of the authentication protocols specified are supported
[12012:12012:0407/021232.394851:ERROR:zygote_host_impl_linux.cc(90)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

Could you please help me run the VPN successfully?

What version of Parrot are you running? Parrot Security, latest updated version

What method did you use to install Parrot? Debian Standard

If there are any error messages or relevant logs, post them below:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.