Black screen after grub on parrot 4.11 beta 2

During the beta testing and full upgrade, we confirmed that latest version of Parrot has a bug that couldn’t load plymouth theme (splash screen). Everything is just black screen and a white cursor. This problem is not the graphic driver issue. Recover mode doesn’t work and old kernel version (w/ recovery mode) doesn’t work either. So i created this topic to track this issue and try to find the bug + fix method.
Image Source: https://www.golinuxcloud.com/linux-boot-process-explained-step-detail/


p/s: i’m no good at Linux boot processing so from the picture, i can guess the Mounts root PS or Init process has problem.

After checking laptop log, i think 90% problem is lightdm problem

  1. Boot log showed start Light Display Manager service then a line “hanged until done …”
  2. Lightdm log showed Session 2 is already actived THEN huge delay time then [+1015.69s] Seat seat0 changes active session to (emtpy space which should be a number)
  3. Xorg log showed (II) modeset(0): modeline ".... <screen options>" then hanged until i pressed power off

So from what i have right now:

  1. It COULD be the driver issue but it doesn’t make sense because booting with old kernel doesn’t fix problem. Also boot into grub doesn’t work
  2. Lightdm is working on my pc.
  3. laptop showed outdated micronode or something like that (old fimrware version)?
  4. Recovery mode REALLY loads lightdm?
    P/s: likely i was wrong and all syslogs are outdated (lsat time i used laptop) except the lightdm log

Could be a similar problem
https://bbs.archlinux.org/viewtopic.php?id=256509

User Jason Derrulo on Telegram is having same issue

Dell 5537 15R
I5 4 th gen 
6gb ram

My laptop

Core i7 7660 HQ
8gb ram
amd graphic card but very old and has no driver

It is possibly the problem is the graphic driver, intel but it doesn’t make sense when recovery mode doesn’t work

@Masmer i hope you can see this topic. I’m wondering if your laptop (that got black screen issue) is using the Intel graphic card?

Unfortunately (?) I never got a black screen. My main PC does use an integrated Intel video chipset, but I mainly use Parrot in VMware on it. I’ll boot off my Parrot USB with persistence soon, update packages, and see if I experience this issue.

It it just on 4.11 Beta-2 (rolling?, testing?) or being experienced by users on 4.10 as well?

My laptop had this issue. This was about a year ago. Have not tried since. Debian 10 works perfectly fine.

AMD A4 3420m
8 gb ram
Radeon HD 6520g

It is just on 4.11 beta (should be beta 2 because i didn’t test beta 1) and 4.10 is totally fine

You can try live mode of usb. The error happens on live boot as well.

Sorry this topic is for 4.11 beta only.

I installed Parrot XFCE 4.11 Home Beta 2 on a USB 2.0 thumbdrive using VMware and then used the thumbdrive to boot up my PC (BIOS boot). I was able to boot to the desktop with no issues (I shut off screensaver’s and power’s lock screen and uninstalled light-locker first thing).

Well boot in vm is very good and it is working on my pc as well. idk why it just doesn’t work for laptop
Here is a similar problem on arch i think
https://bbs.archlinux.org/viewtopic.php?id=262817

I just booted my Acer 8943G laptop off the Parrot 4.11 XFCE Beta-2 bootable USB 2.0 thumb drive, but the laptop uses a Radeon video chipset.

Thank you. That is weird. My laptop is having amd and it just doesn’t work for some reason (and i don’t think amd is the reason because it never has actual driver)
Anyhow can you mount any disks on beta testing? The polkit wasn’t enabled in startup so it couldn’t enable (on my pc). Enable it in startup applications should fix problem.

I mounted a local (NTFS) 500 GB disk on the laptop from beta 2 without having to do anything but right click => mount volume, then put in the user’s password. I moved a 100 GB VirtualBox VM from one folder on the NTFS drive to another. PolicyKit Authentication Agent is already enabled.

Thank you! I think i disabled it on my pc somehow. Must check it again in beta 3 and also disable light-locker + remove it.

1 Like

in addition it seems its coming up in other places i have been reading on how to solve this… I have reinstalled the grub from the USB install ISO which used DD to write USB drive.

I think you are not having the same problem as mine. Your problem is just grub problem and my problem is a weird problem that reinstall grub and boot with older version of kernel just doesn’t work.

The bug is the problem of intel-microcode package. Downgrade it to 3.20200616.1 worked