Blank screen during login

I’ve been using parrot os for almost six months and was quite happy with such an awesome OS !
As I wanted to run hashcat with a gpu… I’ve installed nvidia-driver and cuda. Nvidia-driver worked fine. After installing cuda, I’m getting a blank screen during login. Somehow went to command line interface and got some info.

Btw…parrot os is dual booted with windows 10
Installed using usb stick
Using hp pavilion gaming laptop
CPU:
Intel i5 9th gen processor

GPU:
Nvidia GeForce GTX 1050
Intel corporation UHD graphics 360

Had this issue about 10 times…I thought that I messed up with installers so reinstalled the OS around 12 times. Now I really don’t know what to do.
I honestly LOVE PARROT OS and it would be great if I could use it !!!
IMG_20201013_153508

I need help please.

How did you install CUDA? write the commands that you have used before. It seems something damage your Lightdm files, try to reinstall lightdm, go to /usr/share/xsessions
and verify If there are some files with Desktop extension, to make sure if those are untouched. What is your parrot version? Mate or KDE? 4.10? Also look in cd /home and then ls -a and there will be a “.dmrc” open it by using nano and check it and take screen shots.

I’m using Mate desktop environment, version 4.10 .

Found a fix by reinstalling the os and installing cuda and nvidia-drivers at the same time.

Previously I used the commands
sudo apt-get install nvidia-drivers
sudo apt-get install cuda-toolkit

Which broke the system

Later I used
sudo apt-get install nvidia-drivers cuda-toolkit

Whick worked perfectly fine !

Works fine unless I install bumblebee-nvidia. So better I didn’t install it.

Thanks a lot for your support parrot team !!

Love you guys !!:raised_hands:

1 Like

Glad to know you solve it, I’ll take a look on it, also I wanted to share this in case you will need it. https://askubuntu.com/questions/689924/bumblebee-intelnvidia-on-15-10-blackscreen-issue

1 Like

Yeah sure, Thanks a lot for your support !!:grinning: