Bluetooth hardware not found

Briefly describe your issue below:
— I recently did a clean full install of Parrot Security v4.6 64bit on both my Dell and my Lenova laptops. Before in previous versions I always had a bluetooth icon in the systray and it just ran automatically. I have tried reinstalling bluetooth software/drivers and nothing helped. If you need any additional info please let me know but I NEED to figure this out quickly. I use bluetooth for my work, need it working yesterday.

What version of Parrot are you running?
— Parrot Security v4.6 64bit (installed to both Lenova and Dell laptop same issue with new install)

What method did you use to install Parrot?
— Debian Standard

Configured to multiboot with other systems? (yes / no)
— No

If there are any error messages or relevant logs, post them below:
— No bluetooth adapters found, daemon not running, can’t start up

Hi @PaganPriest,

Can you try running sudo systemctl enable bluetooth && sudo systemctl start bluetooth. This solved the issue for a few people in the community recently.

5 Likes

no bluetooth adapter have been found os parrot home

The decision of the
systemctl start bluetooth.service

  1. Thanks for that, that worked perfectly. I had completely forgotten to use “enable”.
  2. I did want to point out, however, some details for other people visiting this post in the future…
  • Please look at the date of this post, as v4.6 of Parrot Security has not been out for long at this point.
  • This only happened when I installed the new 4.6 version on both my Lenova and Dell laptops.
  • I also kept getting screwy and major errors on the additional software packages I normally install.
  • After trying this fix to see if it worked (and it did) I opted to re-install v4.5 of ParSec since I truly need my systems to be completely stable before I try using them for work purposes.

Thx again for the quick reply and the help!

1 Like

Glad to help.

Yes, this is only occurring on version 4.6 as far as I know. Previous versions 4.5.1 and 4.5 didn’t have this issue.

so after a complete new install of 4.6 ParrotSec, my system was up and snappy, but the bluetooth was still not working. I tried the above suggestion: “sudo systemctl enable bluetooth && sudo systemctl start bluetooth” – and what do you know, it worked, and I got to hear and talk through the bluetooth headset device…until the next reboot.

Then it was back to “Connection Failed: blueman.bluez.errors.DBusFailedError: Host is down…”
with no suggestions posted here or anywhere I could find seem to work…back to square 1.

Re-pair the device make sure the adapter discoverable

already tried that - the issue is linux (all distros) only has part of the needed drivers for the multi-function chipset, so the problem will continue to be buggy at best till a real update is configured. I have written another recent post on this issue, hopefully we can get it resolved.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.