Boot Installation Failure


#1

What version of Parrot are you running? (i4.4 , Parrot Security)

What method did you use to install Parrot? (parrot-experimental)

Configured to multiboot with other systems? (yes)

Hi everyone!
For those who are trying to make the manual partitionning method, I think you need to just set two partiton; one for the root file system (ext4 or btrfs) and a swap partition. After the system installation, the system installation pogram will ask you where you want install the grub bootloader.
That’s what i tried and it’s worked for me.


(Jacob) #2

I’ve had a problem post install (installing from an Etcher flashed USB, PS 4.4 64bit) displaying a list of power errors and acpi errors, then "Alert! /dev/disk/… does not exit. Dropping to a shell

initramfs:_ "

I retried a few different methods and ran into some instances of grub installer errors and trying several manual settings trying to figure out what I was doing wrong, but then found some instances of the same alert for other distributions and I’m under the impression that the bootloader can’t locate the boot drive, and need to experiment with a couple possible solutions. Did you run into anything like this when you were manually configuring the partion settings, or can I rule these things out as being unrelated?


(Nico Paul) #3

thats usually a multiboot issue primarily but def not limited to that


(Jacob) #4

I found an Ubuntu forum that may have resolved a similar “no device” issue using the liveCD terminal to mount the drive and configure the install, I’ll test that when I get a chance.

I’m going to scope out the Debian reference and see what it says about manual partitioning.


(Nico Paul) #5

most here prefer to manually i believe, i typically have an esp part around 700 MB and then a swap part (running 32 G ram so 32GB swap then 1 or more btrfs or ext4 partitions depending on size and machine needs.