Boot issue on Desktop but not Laptop


#1

Briefly describe your issue below:

—I’ve been hitting my ahead against a wall all day over this. I finally got a large enough pen drive to install Parrott Os on. I have been running it in live mode on a small drive with a large amount of success for a while. When I install it on my pen drive it will boot on my laptop without any issue and it works great. Problem being my laptop is a $100 asus POS. So i’ve been trying to boot from my desktop. I have an MSI MPG 2390, with an intel i7 core, with 32 gigs of ram. When I go to boot from my desktop, it shows the usb device partition and will allow me to click it, but it wont do anything just flash like nothing happened. I have secure boot off, and I have uefi / legacy enabled. I am literally losing my mind over this any help is appreciated.

What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Aaryan Saharan) #2

Try removing and re-inserting the Pendrive at device partition.
Or try burning a dvd. I had the same problem , but with dvd. It worked


#3

I tried this and it failed to boot and sent me to a very basic version of command prompt. I also tried other USB sticks, and a dvd. I’m running into the same error on all of them. I’m using parrot security, could this be an issue with the fact that I’m forcing the UEFI, or that I haven’t allotted space for swap space?


(Aaryan Saharan) #4

Use virtual box


#5

I did that previously and it was having issues accessing the drivers for my wifi adapter that I use for monitor mode haha I just dont understand why it works on my laptop without an issue but not my desktop


#6

What are your hardware specs on your desktop?

Parrot doesn’t have swap files because we use btrfs as our file system (loosely put swap is builtin to btrfs)

It’s most likely a hardware issue.