Broadcom won't work in monitor mode

Briefly describe your issue below:

—Release 3.11 64-bit
Kernel Linux 4.14.0-parrot13-amd64 x86_64
MATE 1.20.0

Install from USB thumb drive.

Configured multiboot.

Problem: Network controller
product: BCM4313 802.11bgn Wireless Network Adapter
vendor: Broadcom Corporation
configuration: driver=bcma-pci-bridge latency=0

This interface wlan0 doesn’t support monitor mode

broadcom-sta-dkms Kernel
b44 b43 b43legacy ssb brcmsmac bcma

This same wireless adaptor will run kismet in monitor mode in Linux Mint. It will not in this version of Parrot. Last version I had to use Prism0 instead of wlan0 but worked fine including monitor mode and attack mode. I have tried wlan0 and Prism0 in Parrot but will not monitor.

What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

My version is: Parrot GNU/Linux Release 3.11 64 bit Kernel Linux 4.14.0-parrot13-amd64 x86_64 Mate 1.20.0
Hardware: Memory 5.3 GIB Processor: AMD A8-3510MX APU with Radeon™ HD Graphics × 4

Method of install was from thumbdrive written from parrot download .iso
Multiboot – yes

$sudo iwconfig wlan0 mode monitor
Error for wireless request “Set Mode” (8B06) :
SET failed on device wlan0 ; Operation not supported.

NONE of my wireless programs will work now. All previous versions did. As stated above Kismet will run in LinuxMint Mate but not in Parrot Mate. I have spent several hours trying different things including looking at my installed wifi files and comparing them with LinuxMint wifi files. What have you done to crash so many wifi cards as I see others in this forum with the same issue? The least you could do is give us a reason they no longer work! Are there any work around? Will we need to add a repository to download additional files to make it work? The drivers I have now DO ALLOW me to connect and use internet to upload and download. This seems to me like they are stripped down drivers that only allow internet connections and nothing else. Etherape won’t work. Wiifite, Fern, cowpatty, airomon-ng…NONE work. Why did you remove the driver that lets my wifi work as it should??? NOW my laptop is useless to me in regard to wireless. You did get the VPN working for my laptop but not my workstation. I just don’t understand why so many things stopped working because of one update and haven’t worked since. How about one of the main programmers give us ALL an explanation of what and why all of this is happening.

1 Like

Kill conflicting processes before running wifite or kismet
sudo iwconfig wlan0 down (doesn’t work on newer OS)
sudo airmon-ng check kill
sudo airmon-ng start wlan0
run iwconfig to check for prism0 which is the monitor
sudo airodump-ng prism0 (starts recording all wireless traffic)

I never could get fern to work.

did you double check that the driver you use is supported in the 4.18 kernel? thats been the issue at least with realtek lately. you can try github but im not sure what6 the cause may be. I assume you upgraded to 4.4 since this first post? can you clarify your question list just so i make sure i understand correctly?

Check if b43 drivers support your chip and then using modprobe switch to b43 drivers. I had the same problem and it did work for me