Calamares Fails to Partition USB SSD

– Please Write here your help request –

Calamares (Live Boot) fails to partition USB SSD. I have tried with different options and checked the hash but for some reason I keep getting a failed to partition error while formatting the disk. I tried to format it manually using GParted but that also fails with an “Unable to Satisfy All Constraints on the Partition” error.

Ideally I would like to install Parrot on the the SSD (1TB) with LUKS. I also checked the hashes on the installer and flashed the Live USB a couple of times to rule those steps out. I also zeroed out the first MiB on the drive to make sure any residual shennannigans are not taking place.

Any Help would be much appreciated, Thanks!

  • ParrotOS iso in use:


  • Application used for flashing the iso:


  • Logs/Terminal output (use pastebin or similar services):


  • Screenshots:


did u try installing with “erase disk” option?

What kind of partition table type (MBR, GPT) are you using on the USB SSD?


Ive been using the “Erase Disk” option. Main reason for doing that is for the automatic LUKs formatting for encrypting the drive. Also what I have noticed is that it fails right after wiping the drive (dont know if that means anything)


I tried it on both MBR and GPT - A little pretense; I have had parrot os working and installed before (it was a much earlier version before calamares was being used) using GPT. I also tried to using different file formats (NTFS, ext4, fat32). I figured instead of doing an upgrade, I would just flash the drive and start from scratch.

What it looks like (and I can be totally wrong as this is an assumption) is that regardless of how I flash it, if I choose Erase Disk, it will flash it and use whatever calamares “defaults” too. In this case its always GPT. So I am assuming after the flashing takes place it “should” reformat and partition the drive with GPT. The problem is once it hits the partitioning phase, it fails out for some reason. I read somewhere that Calamares uses GParted to partition the disk, so one thing leading to another I said, let me try manually creating the partitions in GParted. Unfortunately Gparted fails with the error mentioned in the first post and I cant find any information around that obscure error message. Its great that it cant satisfy the constraints but “WHY” cant you do it…

Anyway ranting aside I also tried executing calamares with sudo in case it was a perms issue. The odd thing that I have noticed as well is that calamares sometimes has an issue retrieving the initial packages on start up (dont know if thats related) and it will just keep searching; cant kill the process or daemon using sigterm (which was something new to me - sigterm is usually the nuke option) or systemctl. The process still exists but it doesnt do anything.

Sounds like you may be trying to create a disk without leaving a certain amount of required free space. As if the “Align to” in GParted is set to a different value than your disk is expecting.

As far as the free space - Thats what I thought (At least I think we are on the same page) so I played with the free space preceding a little (I used 1MiB 2MiB 5MiB and 10MiB). Then I used the rest of the space as 1 partition just to test.

For the “Align To” I chose both none and MiB (didnt try it with cylinder because I believe Calamares defaults to MiB) and I still received that error.

Also keep in mind that the only reason I even started to mess with GParted is to try to figure out why Calamares cannot partition the drive and to attempt to identify a more manual fix so that I can re-run the Calamares installation without any issues as it uses (I believe) GParted to partition the drive.

End Goal is to run Calamares with the “erase disk” option and encrypt the drive with a password.

I want to say maybe Calamares / GParted dislikes 1TB SDD’s (Too big maybe?) but ive used this drive for parrot in the past soo I dont exactly know whats going on here.

I guess what I am asking is if there is some sort of workaround to getting parrot installed on my SSD

Did u refer the docs?
But with this, read the dualboot with windows document too, yeah even if u don’t have windows u will get some more idea about partitioning.
And overall u just need 2 to 3 partitions.
1 for boot - mountpoint /boot/efi
2nd for root - mountpoint /
3rd for swap if u need it
Over that, it’s your wish to keep more partitions for your use.
And for /boot/efi, your bios should be changed to uefi if u r in legacy mode.

I did - the docs are not really helpful with troubleshooting.

They go through the steps of installation but nothing much beyond that.

Also oddly enough I can partition it the way you recommended - for efi and root however! I cant do it with LUKs which is kind of the point.

Is there any higher level support with parrot? Maybe talk with an engineer or dev to get more into the weeds for troubleshooting?

I do want to point out that the fact I can manually partition in the way that you mentioned makes absolutely no sense if I cant manually partition using gparted. Im sure theres a logical reason somewhere but I don’t see it - thats why I would like some higher level troubleshooting in how calamares runs is automatic installation and if there is an alternative application I can use to install the os

Also! Happy Holidays :smiley:

Aha~! another side thought - If its not feasible to get a higher level of support, would it be possible to download a version that doesnt have calamares as the installer and use the older one?

Oops! No, don’t. Old versions might have some issues which are fixed in the latest release and it might not get fixed even after updating and we cannot provide support for that.
So it’s better that u try new version.

Here, you are already in direct contact with the developers.
But some might be a Lil busy but maybe u can get them on telegram - Telegram: Contact @parrotsecgroup

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.