Can not write to some USB flash

Briefly describe your issue below:

What version of Parrot are you running? (include version, edition, and architecture) Parrot Security Release 3.11 64-bit

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) Debian Standard

Configured to multiboot with other systems? (yes / no) No

If there are any similar issues or solutions, link to them below: none

If there are any error messages or relevant logs, post them below:
I get this error: “error while copying to " 616A-9F31” destination is read only ."

I have tried changing the permission to the USB drive to rwx but it dosen’t work
I have tried commands such as: sudo chmod a+rwx /dev/sdb1,
sudo chmod a+rwx /dev/sdb1 /media/myName/616A-9F31
sudo mount -f -o remount,rw /dev/sdb1
sudo chmod u+rwx /dev/sdb1

I have even tried several reboots and have also powered off the laptop and on again if naulilis was the cause of the problem; yet it was still unsuccessful. I could not write to the usb flash. However, I was a able to write a text file into the usb flash using a windows computer.

What do you think might be the problem?


I’ve had this same issue! What I ended up was running “GParted” from the menu and selecting the flash drive and deleting all partitions, then reformat. It was happening to me because somehow there were several partitions created on the flash drive. Let me know what happens! Oh, and do be aware that deleting the partitions and reformatting does delete everything.

Ok. Thank you. I will try that out with that same flash later on; and communicate my findings.

You can try to mount the volume as root and then change the permission access to the mounted file, the best way would be to not preserve root user as owner of the key but only the user, using chmod.

I tried your suggestions and it worked. Thanks. Sorry for the late reply. The flash drive in questions was not really mine.

However, I still have a question. How come Parrot OS was not able to write to the flash drive directly when a windows Os was able to do so without stress. I thought linux distros had more advantage in terms recognizing multiple file partitions and type; and as such could write to them more easily.