Can‘t access date on persistent usb

I recently created a persistent USB with Parrotsec and everything worked fine. Now I have a problem: The stick is persistent but I don’t have the rights to change anything. I wanted to save a simple office doc there for testing and it says I don’t have the rights for that. I already tried giving the Debian live user all rights I could tick in the settings as well as creating a new account with all rights but nothing worked. Can I get any help?

PS: This isn‘t as important as the first problem but is it possible to encrypt the persistent usb sp you have to type in a password before you can use the os?

(Post has been withdrawn by user due to wrong answer)

Never ever do this. Ever. Nobody ever do this. This is the opposite of what parrot is. Learn how to firejail Firejail howto in 2 mins 3 sec and let parrot do most of the work. Elevate what you need that is specific to you (you may only have a few things you need elevated privs with) but it’s far less work than you think and eons safer

1 Like