Cannot eject External Harddrive once plugged in ?

Please read this post as I like to show a bug in parrot os.
Once I plugged in and compelety copied some files from my external harddrive to parrot os, I cannot safely remove the drive and it’s showing device busy. Especially when I copy PDF files. Error shown is below:
One or more files on this device are opened in application “thumbnail.so”.
what is this “thumbnail.so” is it any kind of rootkit or virus or simply os program.
How can I forcefully eject the drive without unplug the cable and also I tried following command which are completely useless in this situation.
umount -fl /dev/sdb1
Any other more advanced safe removal command???
After this I cannot even eject in anyway. When I remove the usb cable it causes error to my drive and damaged a external harddrive eventually.
The worst bug is this: If I connected a drive and even at it’s idle state(not using) and when I turned off my laptop manually, unlike windows which will eject the drive first before shutdown, parrot os abruptly shutdown without ejecting the drive and I can hear the slow fading voice from external drive when they are suddenly removed with out ejecting safely. This cost me one drive where I kept my backup data.
So please help me to solve this bugs as it will eventually make impossible to use any external harddrive with parrot os. My OS details are shown below:
PRETTY_NAME=“Parrot GNU/Linux 4.9”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.9”
VERSION_ID=“4.9”
5.6.0-2parrot1-amd64

this is a library which is used to generate Thumbnails

i don’t think this is a bug ,it is a process
probably your drive had plenty of Data due to which it needed more time than you gave it.

you can turn of this by going to File Management Preferences > Preview
*then set it like this (Mate DE)
Screenshot at 2020-06-23 tgrtbv3

Thanks a lot. I am using KDE enviroment. Also can you suggest a way to forcefully eject the drive.

have you tried looking at the processes?
you can see and kill the respective process with its pid
for viewing the processes you can use either
ps aux or htop
and to kill a process, you can do
killall PID

If it is file read slowdown, on KDE the process you are looking for is called baloo, and it’s a bit of a pain in the butt…
https://community.kde.org/Baloo/Debugging
ejecting the drive should be easily accomplished from the terminal by using

sudo umount /dev/sdX
where X is the drive in question