Cannot get past Grub when trying to install. - Blank Screen

For some reason, I cannot get past the grub bootloader, no matter what I try. When I select any option I just get a blank screen. Even if I remove the quiet tag, I still get nothing. I have tried multiple ISO files, multiple thumb drives, and multiple USB ports. I am at a loss. Any input would be greatly appreciated.

I have been trying to find a solution to this issue, but I honestly have no idea what is going wrong so I may not be searching effectively. I have been trying to find a solution to this for days, so don’t give me grief about not searching, please. I have been searching and browsing looking for similar issues.

Secure Boot is Disabled

I wrote the Parrot-security-4.10_amd64.iso using Rufus 3.13 as DD

Here is the info I can gather from the laptop’s BIOS:

Dell Inspiron 5555
Service Tag 8643062
CPU AMD A8-7410 APU with AMD Radeon R5 Graphics
*(I’m assuming the problem is here, but have not been able to find any information that tells me how to install with an AMD GPU. Just a bunch of posts on how to install drivers on an already running system.)
6144MB DDR3L 1600MHz RAM
BIOS Version A06

Etcher is recommended software. Please use it to make USB.

I definitely tried using Etcher several times.