Cannot install ParrotSec VM on an i5 laptop

Hiya, Amelia here. I cannot install the KDE or MATE version of ParrotSec on my laptop in virtual box all of a sudden. When I open the VM and click Try/Install, I get the message "This kernel requires an x86-64 cpu but only detected an i686 cpu. I have never had a problem installing parrot onto a vm with this laptop before until now.
CPU - Intel Core i5-9300H 2.4gh


  • ParrotOS iso in use:
    parrot-kde-security-4.11.3_amd64.iso

  • Application used for flashing the iso:

Downloaded ISO

Laptop specs:
Screenshot_2022-01-13_18-17-59

Hello. Have you enabled virtualization from the BIOS? Check it out, because surely you can create VMs.

The error is showing what it needs: you set the vm an i686, which likely 32 bit (?) architecture and the iso requires x86-64 architecture