Cannot Run Ghost-Phisher Help needed

Hi there as title says I need help to Run Ghost-Phisher. If I try to run from >Menu>Ghost-Phisher
After the click nothing is opened (Nothing happen) So I try to run it from terminal
and I get this error:

Blockquote $ghost-phisher
Traceback (most recent call last):
File “ghost.py”, line 15, in
from gui import *
File “/usr/share/ghost-phisher/gui/ghost_phisher.py”, line 19, in
from core.ghost_dns import *
File “/usr/share/ghost-phisher/core/ghost_dns.py”, line 33, in
from scapy.all import *
File “/usr/local/lib/python2.7/dist-packages/scapy/all.py”, line 10, in
from .config import *
File “/usr/local/lib/python2.7/dist-packages/scapy/config.py”, line 11, in
from .data import *
File “/usr/local/lib/python2.7/dist-packages/scapy/data.py”, line 184, in
TCP_SERVICES,UDP_SERVICES=load_services("/etc/services")
File “/usr/local/lib/python2.7/dist-packages/scapy/data.py”, line 109, in load_services
f=open(filename, errors=‘ignore’)
TypeError: ‘errors’ is an invalid keyword argument for this function

Are you have same problem while try to run ghost phisher?
I would be grateful if you guys help me.
Thanks.

Does it work if you run ghost-phisher with sudo ? Also did you modify in any way your python installation ?

It does not work with sudo and without. No I didn’t edit python installation…

Are you on latest Parrot, which is 3.11 ? I tried boot on VM and can’t reproduce that error.

1 Like

Yes I have latest version…x

launch sudo ghost-phisher!