Cannot start cups service

I have a problem to add a new printer!
In case opening printersettings I get information printer service not available.
Trying to start the service effect no change.

Using Parrot 11 AMD64 standard

Did you try as root “systemctl start cups” from terminal? what error do you have?

1 Like

same result starting cups and cups-client as root.
=> Failed to start cups/cups-clent.service:
=> Unit cups/cups-client.service not found

#Deltadave Its not possible to open the included driver instaler

cups/cups-client??..mmmmm I dont know…

I did it like this:
sudo apt install cups
sudo systemctl start cups

After that, open a browser (Firefox) and point to : http://localhost:631


This guide has pretty much all the trouble-shooting you should need. I am too lazy to retype it plus the guy who wrote this is much better than me :wink:

Good luck with CUPS and let us know if that works.




Okay I got it! :rofl:
I could not install and start cups.service -thats why I tried to start cups-client-
The package “” wasnt activated in Synaptic-Packagemanager.
After this I can start the driver installer
…and try to install the printer driver
… but that will be another story :roll_eyes:

1 Like

Send me printer make and model and I can search the driver for you.

Hp Deskjet 2130

This has all HP supported printers

Mission Accomplished! :gun:
By using standard cups-driver. :smiley:


Whoop Whoop :scream: