Can't detect any USB (storage/mouse)

Parrot won’t detect any of the USB devices I plug in.
Tried all devices in my friend’s laptop (Windows OS) and they worked fine.

I don’t think all of my USB ports are dead. Has this happened to anyone else?

Any help is appreciated (very noob and new to linux).

Linux parrot 4.18.0-parrot8-amd64 #1 SMP Parrot 4.18.6-1parrot8 (2018-09-07) x86_64 GNU/Linux


I installed Parrot using Debian Standard

It is not configured to multiboot with other systems.

and see if you can see it. If you arnt sure what its called just pull the mouse (or whatever) out and run the command again. They should show up in the list.

Wont solve the problem, but its a start.


Hey Matt,

I tried lsusb, as you suggested, and it would only show Linux Foundation 2.0 root hub, Linux Foundation 3.0 root hub, Intel Corp. and the camera.

My friend suggested to clean up the kernels using sudo apt autoremove

After doing that I typed again lsusb and it showed Logitech, Inc. Unifying Receiver, which is my mouse - and it works!

Thank you for helping me :slight_smile:

cleaning old kernels have nothing to do with your issue

plug the usb drive in and then give us the output of sudo dmesg

when i use the sudo dmesg command, it still didnt solve the problem am using grub

usb probm