Can't install 4.7 with disk encryption

Briefly describe your issue below:
I’m trying to install new 4.7 version with fde following the installation guide in debian installer. first i tried to configure a swap partition and a separate home partition but i didn’t reach my goal and gave up. now i just want to install a full disk encrypted and don’t care about swap or separated home partition. it says me:“waiting for encrypted device…” and doesn’t prompt for the passphrase. I’m using parrot for about a month and when i installed 4.6 version I was able to set both swap and separated home partition in full disk encryption. now I’m trying a fresh 4.7 installation and facing these problems. ps: sorry for my english

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64) 4.7

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) I tried all

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

1 Like

We found issues in 4.7 version and we are working on it. I’d suggest you install 4.6 version and run full-upgrade for better experience.

1 Like

Yeah, you right, but doing a full upgrade doesnt give us the new and clean set of tools that we need, such as the ones used at installation, Am I right?

I don’t think so. It depends on the tool and how it was packaged. I haven’t seen anything like

ofc if you have an example, we can do the test and discuss about it. But from my experience, there is nothing different between upgrade and install from new version (except your custom config files etc).
P/s: python-faraday is an example of package that use installation script. If you upgrade it, it will run the installation script because that is the rule of package.

1 Like

yep, the main difference is in the installer and packages coming aboard. If you upgrade the system you get the same tools as if you installed the parrot4.7 and then ran the parrot-upgrade

looks like initramfs problem, we’re working on it.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.