Can't install on live USB, Windows 11 *SOLVED*

– Please Write here your help request –
Hey! I’m trying to live USB boot ParrotOS Security Edition to my Windows 11 Laptop, but I’ve been having many issues. Using Etcher, it’s impossible to even get the flash to succeed, it fails after verification fully completes and splits my drive into 2 partitions, both unusable, and I’ve tried 10+ times. Using Rufus, it works fine, and the contents of the USB appear to be correct. I’ve tried GPT and MBR, both no to avail. I use a different USB of the same exact type to boot into Tails and it flashes and boots just fine (i don’t know if this is actually relevant information). If I boot into boot menu, the USB isn’t detected at all, and if I restart via advanced startup options and select boot from USB, it says “The selected boot device failed.” I have Secure Boot disabled and my bios is UEFI. I haven’t tried it on other devices and haven’t tried other USBs, but if this type of USB works with Tails it should work with ParrotOS, no?

SOLVED
Downloaded ISO file on a different PC and flashed using Etcher there. Worked perfectly. Still not sure if it was my laptop that just couldn’t flash it, or portable Etcher not working, or if the ISO file simply got corrupted during download on that device.

Took me a while to figure this out because I had already decided Etcher would not work at all, so I was only using Rufus.

  • ParrotOS iso in use:
    5.0.1

  • Application used for flashing the iso:
    Etcher and Rufus

  • Logs/Terminal output (use pastebin or similar services):
    None yet

  • Screenshots:
    None yet

If you wish to keep Windows as your daily drive, then you must Disable Windows Quick-start , [usually found in the bios under battery or power settings] and enable the short boot menu to boot the pen-drive

1 Like

Check your raid setting in BIOS could fix this error. I tried Parrot OS on my Gigabyte G5 KC and it failed multiple times until i tried different raid option.

1 Like

Thanks for this tip! Although I had already solved my issue, this solved my issue instantly sucking up 5% battery every time I booted or restarted my laptop.