Can't install Parrot on VBox Step "System Install failed"

Hi everybody,

I’m running Parrot KDE Security at least I try to run it :confused:

I tried the standard install and the GTK GUI install methods

I try to install ParrotSec on virtualbox but the install fails every time

It says “A step of the installation failed. You can try to execute again this step from the menu or skip it to choose another one. The step that failed is : System install”

I checked the hash of the iso and there are the right one so my file doesn’t appear to be corrupted.

Do you have any idea what this problem can be caused by ?

Thanks in advance for any kind of advice

share virtualbox log (please consider using pastebin if log is too long)

VBox.log (94.5 KB) VBoxHardening.log (522.6 KB)
When I check the virtual console, it says “base-installer : error : The tar process copying the live system failed (only 24099 out of 392900 files have bee copied, last file was )”

https://pastebin.com/yEhQtx7J the VBox.log.1 file

I finally installed it. I needed to make a manual partitioning because the guided one made my installation crashed. But now I have a black screen and a blinking cursor after it says “parrot login :”

good to hear that installation is complete, about the black screen inssue can you drop into tty shell.

try ctrl+alt+f1 if you get login prompt login to your account & try sudo journalctl -p 3 -xb to check errors.

I can start a prompt, I can login but when I run systemctl it says option invalid “x”

when i use the --failed option I have “beef-xss.service”,“hostapd-wpe.service”,“lightdm.service”,“rngd.service” and “sslh.service” that have a failed state but are loaded. But both Active and Sub are failed for all of these services

I am very sorry it’s not syatemctl it’s journalctl

if lightdm is loaded but getting failed means it’s something wrong with config file.

  • try sudo lightdm –-test-mode --debug

this will show errors about lightdm, most common problem is it’s config file searching for another greeter.
make sure you have lightdm-gtk-greeter package if not then install it using apt.

On /etc/lightdm/lightdm.conf try editing the greeter by adding this line on the [Seat:*] section:
greeter-session=lightdm-slick-greeter

when i make the journalctl command, it says that there is no entries in the logs
when i first try sudo lightdm --test-mode --debug, it says “Process 1427 exited with return value 1” and when i add the greeter-session=lightdm-slick-greeter, it says “Seat seat0 : Failed to find session configuration lightdm-slick-greeter”

I made a clean install. I have a GUI right now but when i start parrot it says that “kdeconnectd stopped unexpectedly” but then I cannot see the desktop anymore nor any other apps. Do you know how to patch it ?