CANT INSTALL WIFI DRIVER

I just install on a new desktop pc parrot-os. I tried to download wifi drivers but couldnt find a solution anywhere. I tried everything i found here but nothing works.


System: Host: stefanos-h410mhv3 Kernel: 5.14.0-9parrot1-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.20.5
Distro: Parrot OS 5.0 (LTS)
Machine: Type: Desktop System: Gigabyte product: H410M H V3 v: -CF serial:
Mobo: Gigabyte model: H410M H V3 v: x.x serial: UEFI: American Megatrends LLC. v: FA
date: 08/30/2021
CPU: Info: 8-Core model: Intel Core i7-10700 bits: 64 type: MT MCP cache: L2: 16 MiB
Speed: 803 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 803 2: 879 3: 806 4: 852 5: 865 6: 802 7: 806 8: 818
9: 840 10: 801 11: 803 12: 804 13: 871 14: 906 15: 1617 16: 801
Graphics: Device-1: Intel CometLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1440x900~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CML GT2) v: 4.6 Mesa 20.3.5
Audio: Device-1: Intel driver: snd_hda_intel
Sound Server-1: ALSA v: k5.14.0-9parrot1-amd64 running: yes
Sound Server-2: PulseAudio v: 14.2 running: yes
Sound Server-3: PipeWire v: 0.3.19 running: yes
Network: Device-1: Intel Ethernet I219-V driver: e1000e
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: d8:5e:d3:66:3f:fd
IF-ID-1: pan1 state: unknown speed: -1 duplex: unknown mac: 3e:c7:29:2c:89:5f
Drives: Local Storage: total: 704.24 GiB used: 6.46 GiB (0.9%)
ID-1: /dev/sda vendor: Patriot model: P210 256GB size: 238.47 GiB
ID-2: /dev/sdb vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
Partition: ID-1: / size: 221.16 GiB used: 6.46 GiB (2.9%) fs: btrfs dev: /dev/sda2
ID-2: /boot/efi size: 299.4 MiB used: 292 KiB (0.1%) fs: vfat dev: /dev/sda1
ID-3: /home size: 221.16 GiB used: 6.46 GiB (2.9%) fs: btrfs dev: /dev/sda2
Swap: ID-1: swap-1 type: partition size: 17.01 GiB used: 0 KiB (0.0%) dev: /dev/sda3
Sensors: System Temperatures: cpu: 16.8 C mobo: 16.8 C
Fan Speeds (RPM): N/A
Info: Processes: 269 Uptime: 49m Memory: 15.46 GiB used: 1.23 GiB (7.9%) Shell: Bash inxi: 3.3.07

Hi. What is the model of your wifi card? Not all desktop motherboards have a built-in wifi chip.

i dont know how to find this
maybe this helps
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (14) I219-V (rev 11)
DeviceName: Onboard - Ethernet
Subsystem: Gigabyte Technology Co., Ltd Ethernet Connection (14) I219-V
Flags: bus master, fast devsel, latency 0, IRQ 123
Memory at 51100000 (32-bit, non-prefetchable) [size=128K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Kernel driver in use: e1000e
Kernel modules: e1000e

Hi,
Open terminal type

sudo apt install inxi && inxi -N

and post the output.

Was WiFi working on windows?? Just asking that is wifi driver is available or working well?

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
inxi is already the newest version (3.3.07-1-1~bpo11+1).
0 upgraded, 0 newly installed, 0 to remove and 113 not upgraded.
Network: Device-1: Intel Ethernet I219-V driver: e1000e

we bought this pc with no os and boot parrot from usb. This is the first time we install a os in this desktop

Now run in a terminal inxi -N [note the space between inxi and - ] and post back the results

Network: Device-1: Intel Ethernet I219-V driver: e1000e

Your installation is not seeing network device 2 [Wi-Fi]

This may help… WiFi adapter not recognized in Debian 11 - Unix & Linux Stack Exchange

If it is a desktop computer it is likely that it does not have an integrated wifi card. You can try to open it and see if it is there, or check your motherboard model and see if it has the wifi chip inside.

If you can’t find it, buy an external wifi card.

3 Likes

apt-get upgrade --upgradable

I would kill (or at least maim) someone for your rig (j/k). But it does not come with built-in wi-fi.

If you plan on one day attempting Wi-Fi penetration testing on your own systems (monitor mode), I recommend an Alfa USB Wi-Fi adapter. Also keep in mind whether your router supports 5 GHz range.

https://www.amazon.com/s?k=alfa+wifi+usb+adapter&crid=3VXCUQ7PQ9LBG&sprefix=alfa+wifi+usb+adapter%2Caps%2C111&ref=nb_sb_noss

1 Like