Can't put interface into regular monitor mode(Security ver.)

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux:
  2. How to not break Debian system: or
  3. If you are having some questions, your answers might be in here:
  4. Your issue might be solved before (StackOverflow is a temple), try this:

1. Your Parrot information

  • OS version: run cat /etc/*release
    NAME=“Parrot GNU/Linux 4.10”

  • Kernel version: run uname -a
    Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.10
Desktop Environment: Mate
Edition: Security

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?

    • Software used: Rufus-3.8p
    • Steps of making USB bootable: Default settings, burn mode: “DD Image” since “ISO” throws an error during installation (happens with Kali too)
  2. How did you install OS?

    • Debian installer or Calamares installer?
      I don’t know, guess it’s Debian

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
    The error is related to wifi, so output of "lspci -nn | grep Network" is:

02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM 4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
- Did you try searching info about this issue on search engine? Please write No or any URL to this issue bellow

Yes, other community closed without a solution posts, StackOverflow and a couple youtube videos.

4. How did you get this error? Are there any steps to procedure it?

1. I installed Parrot OS
2. I ran "sudo airmon-ng start wlan0"
3. It shows me: experimental wl monitor mode vif enabled for [phy0]wlan0 on [phy0]prism0

5. Error log or screenshot

I am able to start listening and injecting packets with “airodump-ng prism0”, since wlan0 doesn’t turn into wlan0mon I’m not able to use tools like airgeddon, wifite or similar. When I try to select wlan0 and put it into monitor mode it says that it isn’t supported (while it is, since I’ve been using this interface as monitor mode with Kali for a while). I can’t use prism0 either as it retrieves that this interface isn’t a wifi chip.

6. If you have any idea or suggestion about this issue please tell us

For what I’ve been reading it looks like that it has something to do with drivers, I tried solving it but there was no success. I tried “modprobe”, updating and upgrading, using “iwconfig wlan0 mode monitor” (retrieves this: Error for wireless request “Set Mode” (8B06) : SET failed on device wlan0 ; Operation not supported.)

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Affects wireless auditing, I have to plug in an external RaLink device in order to perfom it.

3. Any other information about this idea

PLEASE HAVE IN MIND: I’ve been using the mentioned Broadcom chipset with Kali without any problems. I’m loving Parrot’s GUI, it has almost the same tools for auditing but this drivers problem is making me reconsider which Distro to use.

Thanks in advance.

Try the solution at the end of this thread.

I saw that thread before and tried it. But going to try this:

after get all steps above and restart, if wifi driver didn’t change follow these below :
To unload all known drivers (you can pick only one command, if you know which driver is in use) perform:

1:modprobe -r b43 bcma
2:modprobe -r brcmsmac bcma
3:modprobe -r wl
To load specific driver use one of the following commands :

modprobe b43
modprobe brcmsmac
modprobe wl

boom done…
now driver wl chnaged with b43—> that with it can monitor mode work good
this solution for anyone will have this problem.

I’ll answer soon with the result

That didn’t help, the NIC wouldn’t work without the “wl” driver. I tried forcing it using modprobe -f b43 but got no result. Had to restart the computer to make the interface work again…

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.