Can't sync VSCodium & breaks VSCode

1- I was trying to sync my Virtual Studio Code Configs (from Microsoft) to my VSCodium (from ParrotSec) but the log in option is broken, and the sync extensions from vscode arenot working on vscodium

2- I tried to have both (vscode and vscodium) but vscodium breaks vscode

  • Parrot version in use:

VERSION_ID=“5.0”
VERSION="(5.0 LTS) "
VERSION_CODENAME=bullseye

  • Kernel version:

15.14.0-9parrot1-amd64

Logs/Terminal output

apt-cache show code

Package: code
Priority: optional
Section: devel
Installed-Size: 265032
Maintainer: Microsoft Corporation vscode-linux@microsoft.com
Architecture: amd64
Version: 1.51.1-1605051630
Replaces: visual-studio-code
Provides: visual-studio-code
Depends: libnss3 (>= 2:3.26), gnupg, apt, libxkbfile1, libsecret-1-0, libgtk-3-0 (>= 3.10.0), libxss1, libgbm1
Conflicts: visual-studio-code
Filename: pool/main/c/code/code_1.51.1-1605051630_amd64.deb
Size: 65066582
MD5sum: d796f283391a446e0a0e0a5dff3eefa1
SHA1: bc71be71476e0275b2f4b1ea7bbe3cac399f77b1
SHA256: d101b6ee4445875ee115fd19ad6488a70a0780f12659602229bfb433860823cc
SHA512: 5e31b8ef7e72bf465bdb1d6cfccbed6472bfaa5ec0228b2aace8825e21ae33b739a97968dd9161553fff01a23a155cf9d1f6896d7b51130c1981279472c13beb
Description: Code editing. Redefined.
Visual Studio Code is a new choice of tool that combines the simplicity of a code editor with what developers need for the core edit-build-debug cycle. See Running Visual Studio Code on Linux for installation instructions and FAQ.
Description-md5: b38f8538d3cead7a194af6aeeaf02e6a
Homepage: https://code.visualstudio.com/

apt-cache show vscode

Package: vscode
Source: parrot-tools
Version: 4.11.5
Architecture: all
Maintainer: Parrot Team team@parrotsec.org
Installed-Size: 11
Depends: codium
Breaks: vscodium (<= 1.35)
Replaces: vscodium (<= 1.35)
Homepage: https://www.vscodium.com
Priority: optional
Section: metapackages
Filename: pool/main/p/parrot-tools/vscode_4.11.5_all.deb
Size: 4448
SHA256: 5cf5945b69786fa1bda40c5751aa94f3ff716e607d77b0acb59a418023df6d2d
SHA1: b740271bd124ec0a0b58c4a1c8afaf5d14b2bfc3
MD5sum: 1f4c9ca37c2a00cbaa8686211fe3eca7
Description: Free/Libre Open Source Software Binaries of VSCode (VSCodium)
Transitional package. Moved to codium.
.
This metapackage provides the compilers, interpreters and tools
for various programming languages.
Description-md5: 215787939154b0c971c69bb73b933587

I got vscodium because of this error

apt-cache show vscodium

Package: vscodium
Source: parrot-tools
Version: 4.11.5
Architecture: all
Maintainer: Parrot Team team@parrotsec.org
Installed-Size: 11
Depends: codium
Breaks: vscodium (<= 1.35)
Replaces: vscodium (<= 1.35)
Homepage: https://www.vscodium.com
Priority: optional
Section: metapackages
Filename: pool/main/p/parrot-tools/vscodium_4.11.5_all.deb
Size: 4436
SHA256: 2e223aed213c2c51078ca54c7711c393df3be79a43e2d54247c43d08f7bdc2ac
SHA1: 6a7e2298578592ea99bbdb2ffa631ee910aed4e7
MD5sum: 37c1fecb08b055bce2e7c474076dc2ec
Description: Free/Libre Open Source Software Binaries of VSCode
Transitional package. Moved to codium.
.
This metapackage provides the compilers, interpreters and tools
for various programming languages.
Description-md5: f10e67c721c4110c5c23713115172259

yes, while updating or installing the other, it will try to replace the old, but i guess it asks you before proceeding
though both are same, codium is open source software and code is microsoft’s closed source watching you.

not sure about this, maybe this would be a question for their forum? (or if anybody knows, they’ll let u know).